Rev 4.2 Downloaded Early Sunday

Well, we now are running rev 4.2
So far the changes have not been obvious in driving. Will update as we discover interesting differences from 4.0. Love to hear from those that see or know what we might be looking for in the latest update. It does feel really cool that all this happens while I and the car are " sleeping". VIN 2859, 85std with most options

The creep configuration switch went away after my car upgraded to 4.2.

Is there any documentation on the regen dynamically adjusting to driving style? A couple of times now, I've seen a dashed line appear on the dial which seems to limit the amount of regen.

@dtaubert, the dashed line limiting regen is normal, especially in cold weather. It will limit regen when cold, until the battery heats up sufficiently.

@dtaubert - Creep went away? It is still there on mine and I have 4.2. You have to be in Park to change the setting. If you are D it is greyed out.

If your car is virtually flawless it sounds like everyone should go back to OS 3.9 !

I'm still stuck at 1.15.14, too. but everything works just fine. Normally, I like to have the latest release, so it's bugging me a little, but I am enjoying bug-free driving!

Ah, my bad - creep is still there. One of the switches was removed from the Vehicle->Settings screen, but I'm not sure which one.

I believe that was the Sleep function that was removed from Settings in 4.2.

I just received my MS Jan 22, vin 3204 (performance, tech, stereo, twin chargers, no pano), on 23 jan. TPMS warning-tire psse too high on my commute home. I checked and tire pressure averaged 57 for my tires after they had cooled down about 2 hours. I had seen other posts regarding the high tire pressure on delivery, i bled off the pressure down to 42. On that evening I noted a small alarm clock on the top of my screen, pressed it and it stated I was scheduled an update. V4.2. I downloaded it last night. Not sure if I needed it, no pano and no issues except a proper TPMS light. Will update you on any issues. My daily driving is such that the 8mi/wk loss in range is not an issue, however given how new the car was I was afraid to skip downloads designed to fix bugs in the system (even if I did not note them yet)- must be a by-product of my military background, be vigilant.

If you don't have 4.2 and want it, just ask. I emailed ownership yesterday morning and asked about the 4.2 update to fix radio/camera/etc. issues I've been seeing. They called me right back and said they were pushing the update to my car as we spoke. When I got in the car after work the update was there waiting for me.


4.2 was pushed to me this morning without me having to ask

I had an issue last night where the car would not take a charge. Symptoms included white charge ring would not change colors as is normal. Using a Nema 14-50 plug. I unplugged and re-plugged several times to no avail. Switched to the 110 adaptor. Lights appeared normal on charge port and dash showed voltage and current but no range increase.

Needless to say I was concerned and called support. What we did was to reset the main screen using the scroll wheels. Still appeared to operate the same way. We then unhooked everything, closed the charge port door, locked and unlocked the car and tried charging using my normal procedure of using the cable to open the charge port and plugged tha cable in. Everything then worked.

It might be a good thing to remember in case it ever happens to you. I had 1.15.14 installed. Assistant asked what I had and he seems quite surprised at how old it was so he immediately pushed out the update to me. I haven't had time to instal it yet. He did mention that the reason they don't push it out to all cars is their servers get overloaded. I sure hope there are plans to be upgrading that soon as it is apparent updates are going out very slowly.

I was one of those who had no real issues with the prior version and seeing how many issues 4.1 introduced I was not in a hurry to get any updates. We'll see how this one goes.

Theresa, just in case, and please don't go 'Duh!' on me, but sometimes the charge cable doesn't go in all the way and can need an extra push. It really feels like it is seated but it doesn't click all the way.

This has happened to me a couple of times and I thought something had gone wrong. It just needed it little extra encouragement.

Got the 4.2 upgrade last night (after OK-ing the notification box that popped up when I got into the car last evening). I've only had the car for a week, I had 4.0, and I didn't run into any issue or ask for the update. Seems to me that (a) 4.0 was in need of fixing - not just 4.1, and (b) they're going at it fairly randomly - I don't think I had the profile that qualifies for a priority upgrade...

nick, Note that I had port lights and dash indication voltage and current but no mileage charging with the 110 volt adaptor. That tells me that I was indeed fully inserted. And I would be really surprised if after over a month I would suddenly not be inserting the charger correctly when I never had an issue with it until last night.

Do your port lights turn blue and green when you don't have it all the way inserted? And does the charge screen show voltage and current but no mileage charging?

The first time I tried a J1772 connector I had somewhat similar results as far as charging but the indicators (lights and dash) indicated some type of issue. What happened last night was a totally different scenario.

Hi Theresa - that's really weird. No, definitely not seen your problem. Wow. Hope this was a one-off glitch.

I got the notice to schedule the software update, so presumably tomorrow morning I will have 4.2. I will miss sleep mode since I haven't had many problems with it, but hopefully they can add it back before I take another out-of-town trip where I can't just keep the car plugged in overnight.

Just received 4.2 in response to a glitch in 4.1 (faulty low 12v battery signal). In the 4.2 (and 4.1) release notes there is an indication of "location based" homelink which seems to indicate that based upon your immediate location, the appropriate HL icon will deploy. Am I reading this wrong as so far I see no difference in HL behavior regardless of my location.

@mferrazano - I had that in 4.1 -- when you are near the location you programmed a HomeLink, it will pop up the HomeLink menu for you to select. For me, it does it only right at my garage door and I want to open it at the bottom of my driveway, so I am thinking about clearing it and reprogramming it further away.

I apparently update tonight -- VIN 2449

I also got my 4.2 upgrade today vin# 1692

"Theresa | JANUARY 24, 2013
nick, Note that I had port lights and dash indication voltage and current but no mileage charging with the 110 volt adaptor. That tells me that I was indeed fully inserted. And I would be really surprised if after over a month I would suddenly not be inserting the charger correctly when I never had an issue with it until last night."


When my Model S was charging on 110 volts, outside in the Chicago cold the last few days, it effectively showed 0 miles because it was (apparently) using all the juice to keep the battery warm and almost nothing was available to charge the battery. Is that possible in your case?

Is updating via Wifi coming any time soon? I have wifi in my garage. Seems to me, that would be much faster and more reliable than 3G.

I was hoping 4.2 would fix my rain sensor issue (not reliable or consistent so pretty much useless)
I think I see some improvement but not enough, even on the "high sensitivity" setting
maybe with 4.3?

My sunroof works properly now, since v4.2 downloaded last night!

I was finally updated to 4.2 (1.19.42) last night! If you are still running on 1.15.x and wondering why you haven't been updated yet, as someone suggested, if you ask Tesla to push the update to you, they apparently can. (I guess it probably depends on whether they want to or not).

When I had asked about pushing an update earlier (when 4.0 had just come out), I was told that the rollout is automatic. Since 4.0 was rather buggy, they probably didn't want to push it out to any more cars, in favor of waiting for the next update. Now that 4.2 is out and perceived to be less buggy, they must be OK with pushing it out on request.

I just emailed and said that I was still running 1.15.14 and would really like to see some of the improvements in 4.2, and asked if there was any way they could push the update to my car. About an hour later, I went to check the car, and the update was waiting!

Now, that said, it could be pure coincidence that the update happened to come just as I asked about it. Either way... 4.2 installed without a hitch, and now my car greets me every time I come near with the key fob! :-)

GoTesla, I doubt it as I was charging the same location as always (in my unheated garage) and the temps were actually a little higher than the day before. Also my initial experience was using the 14-50 plug which should have plenty of power to provide some charge even if heating the batteries. I live in Iowa so my temps are about the same as yours currently. I think it was just a glitch. I just wanted to post so in case it happened to others they would at least be aware it could happen and they would have a clue as to how to cure it.

One other thing I have noticed with 4,2 which I haven't seen specifically detailed anywhere else... the door handles seem to be much more responsive. Aside from auto-presenting when you approach with the key fob, I feel like opening the door actually requires less force, or the timing is different. Previously, when the handles would only present after you touched them, I had to wait a second before pulling on the door to open it, and it just felt different. Previously, if I pulled on the door too soon, it would not open and then I would have to push the handle back in, push on it to extend it again, and try again.

Now, as soon as I pull on the handle, I hear it unlatch and it opens immediately. Perhaps it is just the fact that the handles are extended for several seconds before approaching, but it feels like something more than that, like the sensitivity to tugging on the handle has improved.

Regardless... I like it.

@mkh1437 - not sure if the handles thing was 4.2 or 4.0; anyhoo...I noticed the same thing and just asked @Rod to remove a request from the Prioritized Software List to remove the delay when opening the door - seems like Tesla fixed it.

I've updated from 1.15,14 to 4.0, then 4.0 to 4.1 (1,19.31), then finally from 4.1 (1. 19.31) to 4.2 (1.19.42). The first two updates took about an hour, and the last just 30 minutes. How long is the update taking going from 1.15.14 directly to 4.2 (1.19.42)?

Anyone know the source of all the clicking during the updates?

X Deutschland Site Besuchen