Foren

ZUR TESLA-COMMUNITY
REGISTRIERENEinloggen

Strange Cruise Control "feature" - can someone check?

In my car I have this behavior:

  • Drive at 30 mph
  • Enable Cruise Control
  • Lift Cruise Lever all the way up to increase speed by 5mph
  • Speed increases by zero or one mph
  • Lift Cruise Lever all the way up to increase speed by 5mph again
  • Speed increases by five mph (and is OK from here on in
    • So... lifting the lever all the way up or down to adjust speed by 5mph works, UNLESS it is the first time you've done it after setting cruise control in which case it seems to do (almost) nothing.

      Can someone else try and see if this is unique to my car, or a 'feature'.

      Thx.

I had some odd CC behavior the other day, but not precisely the same. I pushed the CC lever in, the light went on, but I did not get the CC icon on the instrument panel. I thought, OK, I need to increase the CC speed with the lever. But when I tried it, the speed did not increase, and the CC icon did not display on the instrument panel. I thought it was because the car had been sitting in the cold (I was driving down from Snoqualmie Pass after the car had been sitting a while in 30 degree weather, and I had earlier seen a warning that I might not have full power because of the cold). Anyway, eventually the speed did increase and the CC icon appeared.

I'll try to reproduce the problem next time I'm out.

It has its own mind. I've tried repeatedly but I can never count on precise 1mph, 5mph, 2mph/sec increments from cruise control. I just set it once my desired speed is there.

it sounds to me the CC lever does not increase current speed by 5 mph relative to current speed but instead toggle between fixed steps.

it might be they just used a byte to store the CC level, each step representing e.g. 5 mph step.

if you are driving 76 mph - next CC level could then be 80 mph
if you instead are driving 79 mph and goes to the next CC level, it would still be 80 mph.
(if C levels are ....60,65,70,75,80,85...)
See the point, first time you use the CC lever you might increase by 1 mph or 4, but after that it will go 5 mph each time.

try see if your CC always end on the same fixed speed (might not be a round number like those mentioned here) when going 5 mph up/down - I belive first time you use it, it will not be relative to your current speed due to above mentioned resolution.

I would not consider this as a fault, just something one should know.
tesla could redesign the program, to allow higher resolution for the CC level - e.g. make it a whoopy 16 bit, this will allow a 5 mph increase relative to current speed instead of fixed levels

Sorry NielsChr, your speculation is wrong. The lever does go in 5 mph increments. If I'm doing 38 it goes to 43. If I'm doing 71 it goes to 76, etc.

The lever is sourced from Mercedes and is the same one on my CLS 63. I love the cruise control on my CLS because it allows me to set it at 1 mph increments. Something else it does is it breaks the car when going downhill to maintain exact speed. I love this because it prevents me from getting speeding tickets. I call it "static" cruise control. I am awaiting delivery of my S. Can someone tell me if the S has static CC? My test drive car did not several months ago.

When going downhill car will allow regenerative breaking to keep the car at the right speed, but I don't think it will apply the phsyical brakes.

I can't remember for sure, but I think I did notice once or twice that I went a couple mph over my CC setting when going downhill. It's hard to test because the regenerative braking is so effective.

I believe it works like this - single click up for 1 MPH increment, push all the way up and its a 5MPH increment - I used this on my trip to NYC (from Philly) and thats pretty much how it worked.

@noel - sure does - except for the first attempt after enabling CC. Hopefully someone can confirm or refute.


X Deutschland Site Besuchen