Forums

Join The Community
RegisterLogin

Model S Android App

Just downloaded the Tesla mobile app for Android. All I need now is my S.

I seem to have lost the location map on my app. It worked until about last Thursday. Also, since my car was in service, they reloaded the software and the remote access permission got reset to not. Although they may have done that manually since I told them that I was monitoring the car while they were working on it. They may not have wanted me flashing the lights or tooting the horn while they were checking it out.

@David Trushin - You need to update the app -- if you set it for automatic updates, you should have gotten it already. See the Tesla post about it for more details.

@ Jat

Everything actually runs off of the traction pack as the 12v battery is maintained via a dc/dc converter. however the question is if the draw is replaced with shore power (even if charging is complete)while connected to a charger?

@Superliner

As I mentioned on another thread, I have seen it run the heater without drawing anything at all from line power even though it was connected, and I have also seen it draw 9kW even when it was fully charged as soon as I turned on the heat. I haven't figured out why it behaves differently at different times.

Hopefully a future ota update might solve it "assuming it is a software issue" and not firmware. Preconditioning with shore power is a must for range preservation. Here in AZ I'd LOVE to get in a cool interior after work etc. That one is a misstep IMHO

I'm able to do this with my current ICE by leaving the HVAC in "auto" and initiating a remote controlled start from my keyfob! (albeit with the limitation of having to be fairly near the car) but it does work from within my current office reaching the car in the parking lot.

My guess is that it has to do with the exact state of charge -- if it thinks it is fully charged according to the last charge method (standard vs range), it will run off of battery, and if it isn't (such as it has dropped a few miles overnight), then it will charge while it is running HVAC. This is similar to the way the battery heater works -- it draws from the battery when needed, and then periodically the car will start charging to replenish the power that depleted from the battery.

That's just my guess anyway.

jat;
sounds right, but I gather the "hysteresis" of the "occasionally" is a bit wide. Shore power needs to be used and usable directly, IMO, for this kind of function. What would it require, a 12V AC transformer?

I mentioned this in the iOS thread, but one trick I've tried is to use the app early in the morning to switch to range charge, start charging, turn on the heat (or AC), and switch back to standard charge when rated range gets back up above 240. That way you start driving with warm cabin, warm battery, and 240 rated miles.

DR;
Should work every time. What's been your experience? As long as the car is still actively charging when you come for it, it's all good.

It has worked every time I've done it. However, I don't commute, so most days I don't need to start out with a full tank.

Neither do most commuters! But full power, regen, and cabin heat are always welcome.

I have tried this as well and it does start me off with a warm, fully charged car. However, I was able to duplicate the self "start charging" problem again. It seems that the inability to stop charging from the app might be just in Range mode. I did successfully stop the charging in standard mode 2 nights ago, but last night in range mode the car self restarted charging several times.

It would seem that adding a "time of day" switch in the app to turn off and on charging should be a quick fix, as long as the car does what the app tells it to. Being able to cut our charging costs in half is no small thing.

@Jason2 - the car currently has no way to do anything related to charging based on time, so the app can't tell it not to charge during some time (if that feature was there, they would already have the timed charging functionality). The best an external app can do is to watch the car and tell it to stop charging if it starts charging when it shouldn't. This will definitely be the case when you first plug it in, but I haven't been able to reproduce your report of the car restarting charging after you told it to stop via the app. If you didn't accidentally restart it, is it possible that the app issued the command to stop but it didn't reach the car so the car never stopped and therefore never restarted charging?

Anybody can make the APK file of the Tesla Model S Beta accessible via this forum. I Can't find it on the net. I'd like to try to install it on BB10 and my Playbook.

I can now control my car via the app (I think). The only catch is I don't actually have a car. Delivery not until next month. No other notification of a VIN other than what is on the app..... is this normal?

JoeBadge,

You should call TM. You may be controlling someone else's car. I had the same experience before delivery. The app worked and I could see what I thought was my car at the DC sales office. I could watch it being driven around and knew when the doors were opened, when it was charging, etc. it was the right color but the wrong VIN. That made me suspicious, similar to your situation. So I emailed my DS in DC, and she said they were wondering what was going on, as their demonstrator kept honking it's horn, flashing its lights, and having its roof open and close for no apparent reason.

This was the day after the app was released, so they didn't make the connection. Anyway, after calling me a butthead, I was very quickly disabled on that car and connected up with my actual car, which now shows the correct VIN. It was very funny to all involved, but would not be for a car that was already delivered. In my situation, there is a series of reasons that I was hooked into the wrong car's VIN, making this an unlikely scenario for others, but if your VIN is wrong in the app, you could be accessing the wrong car. The other reason that this is suspicious is that TM does not enable remote app access on the car's settings screen until during the delivery process, so if you try while it is in transit or storage, the car remains invisible.

Joke badge,

You can check the map location on the app to see where the car linked to your account is located. That may provide a clue as to what's up,

Just spoke with TM. @Pungoteague_Dave - The VIN on the app and my actual VIN are correct. Car is sitting in the manufacturing facility as far as I can tell - actually it is driving right this second - now that's weird! But I assume they are almost done with the car.

Joe;
Actually, they evidently have you tuned in to a RC model, just to keep you occupied. :0

Pbrulott,
What's your email address. I can send you the Android .apk directly if you'd like. As of now most BB apps were ported from Android or at least that's what I've heard.
J

My 'Location' view truncates the actual map. The entire map appeared yesterday, but now only appears on the top 5th of the mobile page. Not sure how to upload a photo to this discussion group, but is anyone else having this similar issue? Thank you.

Joe;
No uploading. You can store a pic on a web host, like imageshack, and then reference/display it with HTML:

<img src="URL here" width="600">

I downloaded the app. It wants me to log in. Fine, but the first thing it says after that is there is no car associated with the account. Kicks me back to log-in screen. No possibility (that I could find) to enter VIN or anything. I can log in on the web with the same ID/password, and it knows I have a car awaiting delivery. I even have received the VIN. Please tell me what I did wrong. Thanks!

Does your VIN show up on your MyTesla Garage page?

Trying to log into app - it's been working all week until about an hour ago. Error message is 'My Tesla Could Not Be Reached At This Time". Anyone else getting this on their Android? Thank you.

Getting the same problem on iOS (well, a spinner) - looks like it is a Tesla Server problem.

I've noticed this too!

If anyone has a problem, please call Ownership and let them know. I just called them.

If you're wondering why sometimes the climate settings are changed while you are away, the phone app will change the settings when you turn on climate control remotely. I usually have the settings with AC off and vents pointing across and down. When I activate the climate control from the phone, the AC is changed to auto and the down vents are the only ones set. Plus the temperature is wacky. A moderate annoyance, but now that I know why, I can live with it until they get around to fixing it.

Is there any reason why this app is not available here in Norway ?


X Deutschland Site Besuchen