Forums

Join The Community
RegisterLogin

Squeeeeeky Brakes

I've had really squeaky brakes from day one but the service center says that's normal because we don't use brakes that much. Not really buying the reason and hate the fact that a brand new 100k car sounds like a 10 year old Kia at a stop sign. Anyone else having issues?

No squeaks for me, and do not believe that service center guy.

YMMV - I only had them a few days when I first got the car, and then briefly after the car sits up for the weekend if I don't go out. Others have had them most of the time.

A thin layer of rust does build up, but that should scrub off after a few applications of the brakes, so if it keeps squeaking then it is probably something else. If it sounds closer to grinding, you might have a pebble stuck in the brakes.

4000 miles, 14 weeks, never had squeaks.

I had squeaky brakes for about two days and then it went away. What are your driving conditions like?

Had my car for about 3 months, got 2600 miles. No noise from the brakes.

No squeaky brakes until I washed the car. Squeakiness dissipates over time until next wash.

Had mine for only a few days and still <500 miles and it is squeaking when ever I brake. It's not super loud but I notice it. I don't use the brakes very much and know from prior brake jobs that the noise is not uncommon for new pads to do this. Will wait a little longer, maybe a week and if the noise persists will call.

I have loud squeaking too....not the kind of attention and stares I expected. <500 miles driven so far. The local staff recommended turning regen to low and doing some hard braking to wear off any corrosion/rust. I did this and it helped briefly. Shortly after turning the regen back to standard, the squeaks began again. I"m going to give it another week before I ask service to get involved.

I had a Porsche that use to have squeaky brakes after I replaced them with some high performance brakes. What I did to resolve this was to apply some antiseize on the backside of the pad. This eliminated the noise for me but I did get the occasional squeaky, but it wasn't as bad as before. I would also do a few high speed spots to set the brakes, but don't do this too many times in a row you glaze the brake pads.

Squeaky brakes is just the pad vibrating against all the metal and while it is semi-normal its just plain embarrassing!

I have had mine for nearly 3 months, 5K miles in mostly dry and warm southern California. Getting regular squeaking just at the very end of braking. Not every time but frequently. Seems to occur more often after a car wash lending credibility to the theory it is associated with that, but it still shouldn't occur as frequently as it does.

Notified my service center-- the didn't blow it off, acknowledged that it was abnormal and said a fix is "coming". So, we'll see.

Are you washing your wheels very often? I've noticed more brake noise after I wash my car or the wheels/disks get wet. My brake noise usually goes away after I drive a ways, however.

I live in Southern Cal and I've got about 1200 miles on the car. As in a couple of the posts above, I only notice it as I come to a stop (since that's the only time you need to hit the brakes), but it's very consistent and doesn't seem to change in traffic with the brakes getting a little hotter. The car is a P85, so maybe it's a high performance brake pad issue? Like everyone else here, I'm stunned on a daily basis by this car, but I guess when the car is so perfect in so many ways, little stuff like this seems worse.

Solution(s): never brake, or always brake.

My breaks have squeaked from day one, but only just as I come to a stop. At other speeds they never squeak. I hardly ever use them anyway. It doesn't bother me much. I know it doesn't hurt anything, and they only squeak because they don't get used a lot. I'll be a little disappointed if/when they stop squeaking...

@Brian,

Never brake always break.

Ec;
what do you generally break?

Same as Wayne3. Some squeak/roughness after it sits wet, but goes away quickly. No noise ordinarily.

Always squeaky ever nice I got the car two weeks ago. Brakes still squeak after 1300 miles. I rarely use them.

....ever since I.....

Over 5,000 miles and they still occasionally squeak at the very end of a stop. Moisture definitely affects the sound. I consider it a pedestrian warning tone.

Less than 200 miles on mine and the brakes have had squeaked since Day 1 ... I guess I will be one of those hoping it goes away after some more miles are put on them. I agree though that it's a bit embarrassing to take folks to test drive in the new car and then have the brakes squeak (and with everything else quiet it's easy to notice).

Brian,

Er... the rules?

P85, about 700 miles driven. Also have a faint squeak, at the very end of a complete stop. We called Tesla, was told it was normal. We'll see if it goes away. Sounds similar to what is being described my several above.

Very low speed squeaks, when backing out of the garage, other wise no.
Rocke

Do a google search on 'squeaking brembo brakes' and you will be amazed to learn that its a common issue across all cars with them - Subaru, Alfa, Fiat, Jeep, Ford etc etc.

It's most likely to be because they need to have some bedding in. Turn regen to minimum and drive it like an ICE for a day or so - ie use more brake to slow down. Maybe do a few faster/harder stops to help them bed in.

I have Brembos on my 928 which occasionally squeak after washing the car or parking it wet.

Me too. Started after a couple of days (had the car for a week now). The weather has been pretty wet here lately. I use max regen setting. Will try use brakes more to see if that helps.

As others have noted mine only squeak after washing the car. After some aggressive braking it goes away.

Brakes? The Model S has brakes? Must not be driving it right...

My brakes often squeak when I come to a stop.
I plan to bring it in for service after the Las Vegas Service center is built.

Our brakes squeak fairly consistently just before the car comes to a complete stop. This has been true since day 1 and is still true 7 months and 9K miles later. We've asked about it and were told that is normal. We haven't asked lately but will. If there is a solution, please share.


X Deutschland Site Besuchen