Forums

Join The Community
RegisterLogin

New 4.5 Update Today

I had updated my P85 to 4.5 (1.33.38) quite some time back. Today I received another update and I just got done updating successfully to 4.5 (1.33.54). The release notes are exactly the same as the previous update. Has anyone else received this new update? I wonder what the difference between the two updates is.

Got the update as well. Don't notice any difference. Usually when it is the same release, i.e. 4.5, it just fixes bugs. Not likely to be anything significant.

If there was fan noise behind main display, did you notice any change in the noise? (Hopefully gone?)

Mine came with 1.33.44 pre-installed, which unfortunately has a rare software issue that makes part of the touchscreen unusable. If I ever get 1.33.54, I'll let you know if it solved that particular issue.

Also looking forward to a fix for the fan noise.

Good to know... I lost Slacker Radio after the last 4.5 ver update (last month), so hopefully this update will fix that.

No noticeable difference for me either after downloading it yesterday.

@RedShift, my car started the fan noise after updating to 33.44. I took it in for service and they upgraded me to 33.54 but it made no difference. They said their engineers are aware of the issue, it is not the new normal, and a future update will hopefully fix it.

They are telling me that the fan noise is probably because of the hotter temperatures...so my guess is that when it cools off, the noise will go away!

I did not have the fan noise earlier and don't have it now.

Just installed the update a few hours ago but I didn't get back in the car yet. I was kind of hoping the fan noise would be fixed but it doesn't sound like it was. :(

what fan noise are you folks on about here? There are two fan noises I've heard so far:
1) Fan from the A/C system to cool whatever compressor is in use for A/C
2) Fan to blow the actual air into the cabin for cool/warm air

Is there some other fan noise coming from a fan used to cool the board operating the car/panel? If so I've never heard this fan but will try to listen for it. Live in TX and we are hitting 100's recently so if it is a 'it is hot now' issue I've still not been affected.

New update appears to have fixed the fan noise issue for me.

Go the update last night. No noticeable change in anything. Of course, I just got my MS 5 days ago.

Received 4.5 (1.33.54 yesterday). All new functions work, car still performs as beautifully as ever. I let the wife drive again (gotta stop doing that!) and she had a ball! :-)

1.33.54 did not resolve my touchscreen issue. I haven't heard anyone else mention this issue, so maybe I need to ask Service about it again.

Will see about the touchscreen fan noise in the morning...

can anyone tell me how to do an update, do i have to call Tesla for it?

@MIKE@PARTCRAFT.COM: Your car will notify you when it has downloaded the update. Or you can forcefeed it by going to your service center. I would just wait until your car notifies you - the latest update does not seem worth going to the Service Center.

MIKE;
It comes when it comes. You will be asked onscreen to approve the installation time. It downloads earlier, then installs when the car is parked.

I was told 2 different things. On one occasion they said a future firmware release would fix it, and on another, that they were trying to cool the main display panel by turning on the fan.(implying the fan was mistakenly not turning on earlier)

I am curious about the firmware push out being staggered. Does this mean the cars have different hardware configurations? Besides the battery and whether its a perf model, most electronics should be similar, no?

I don't believe the warmer weather argument. It has been in the 50s here in Seattle in the morning and the second I open the door until the second I leave the car, the fan behind the monitor is on. This is with every option off(AC/heat/radio...)

@RedShift

'I am curious about the firmware push out being staggered'

Not an expert, but guessing they release in batches probably to prevent overload of transmission. Or to regulate the volume of questions that follow so that they do not overwhelm the calls to service center.

And then, there's always that haunting problem that shows up unexpectedly in any release and staggering will affect less people if it occurs.

I noticed it fixed some bugs, namely the browser favorites now work.

@hsadler: so that also means first batch act as beta testers (kinda).

What these guys need is more verification before sending them out.

Speaking as an expert in this field. (Hardware verification consultant)

This is something I did not notice before - not sure whether it was always like this or due to the recent 4.5 update. When the home link control drops down on the screen my rear camera image goes blank until the home link control closes - then the rear camera image comes back. Anybody - don't think I remember that ever happening before. Car is in garage so not sure what version of the 4.5 release I have - too lazy to go down to get it.

I'm still stuck on 4.4 :(

The fan noise issue was identified endlessly on other forums. There was a software glitch apparently, that caused the cooling fan behind the screen to work normally until it got warm enough to require operation to 100% then it stuck at that setting. The fix was to reset by pulling the proper fuse and reseating. I wonder if after the software update, you still have to do that to return it to normal ops. Just throwing that out there.

Fuse pull did not work for me, tried 3 times. Some said it worked, some didn't.

@RedShift

Actually everyone acts as Beta testers.

The more complicated software becomes, the harder it is to test for every situation.

A release is pre-tested (by companies with more integrity - others do not test), for as many situations as is feasible. Hopefully, a fix not only corrects the 'problem' but doe not affect anything else. In millions of lines of code - it sometimes does.
Obvious problems are spotted before release. Minor problems can be found after initial release. The real 'buggers' pop up much, much later.
Nature of the beast.

Other car companies do not fix their 'software' - and yet some do, but see it as an opportunity to make a profit by charging you to have your software 'fixed'.

@rbgliny - Mine has done that since the day I got it (4.4). What's strange, is sometimes it will push the camera image down and still leave it visible. This is preferred, but I haven't been able to nail down the exact situation where this happens.

cgi guy: I did find a solution.....if the camera image is on the bottom part of the display it is ok and does not go blank..and whatever is at the top of the display stays displayed when the home link control drops down.


X Deutschland Site Besuchen