Forums

Join The Community
RegisterLogin

New Software Version?

Took delivery yesterday at the factory and was told that they are starting to roll out a new software version. Said it should DL in next few days. Anyone else aware of this?

I got the "Warning Car Needs Service" this morning too...which went away when I got in the car and put my foot on the brake, but no software update yet. I get the impression from some of the posts above that the update is downloaded on 1 day and then installed on another, but not sure why that would be. I'd think it would be simultaneous, no?

I just went for a ride and my current software says "version 15.14." Yesterday it was 15.8. There's some kind of update, but no email or list of enhancements as promised that I've seen.

I doubt that the next update would be numbered 4.0, given their numbering system. That sounds suspicious to me.

I have NO idea what they enhanced.

Richard

@Mike6: I took delivery of my car yesterday afternoon (P153). Just as the delivery specialist was explaining to me how when software updates are available a little icon will show up on the menu bar, I swear, as soon as he pointed to the empty spot... that icon appeared! Clicking on it opens a scheduling dialogue asking when you want to do the update. Default time is 2AM! So we moved on with the pre-flight instructions.

Cut to: 12:30am. Yes, I'm sitting in my car in the garage in the middle of the night. Doesn't everyone do that on the first night home? Well, like your car, Mike, suddenly my car starts going nuts! Whirring noises. Clicks. Lights! The screens flashing on and off. You have to understand that I have less than
50 miles on this car, and I'm thinking it's about to blow up! I too got the "Needs service" notice, and a string of other warnings. Currently my "speedometer" screen will NOT shut off when the car is powered down. It keeps cycling like it wants to shut off, but stays on.

Bottom line, this car is more like a computer than a car. Updates are always a dicey proposition, and you never know what may get broken. (Like my rear view camera which now seems to come on only when it feels like it!

I'm confident that these bugs will get worked out soon. Bottom line, the important stuff, like performance and handling are AWESOME and just work! But, I'm sure we will be dealing with details for ever!

I do hope they run some sort of dual partition or dual firmware setup inside of the vehicle. That way the "flash" or update process can fail, but it will resort back to the backup firmware/partition to keep the car operable until the update failure can be resolved or the car can be serviced. It doesn't have to be a full backup operating system, just the basics to be able to get it back online and able to retry the update (or restore from a known working copy).

Many enthusiast computer motherboards have features like this because they tend to brick them with bad flashes. It's a premium feature, but I would expect it's in this kind of car.

@timdorr Really any embedded device that does OTA updating works that way. I work on consumer products, and we do this even in little things like wifi scales. It's incremental cost in storage space and huge savings in support costs. If Tesla didn't do ping ponging of firmware, I'd be extremely surprised.

I'm posting this for those (nervously...as I once was) waiting and or newly cradling their Model S. I've had my car since Oct 24th and have not experienced 1 problem! Friends & family ask, and yes there are things I "wish" were included, but absolutely nothing has gone wrong or disappointed!!! (I remind myself that if Tesla delivered "the perfect" car out of the gate where would they go from there)? Everything promised & delivered has worked perfectly. THE CAR IS REMARKABLE! repeat REMARKABLE!!! The updates will be welcome "icing on the cake"! I'm 1,700+ miles in and I haven't set foot on a gas station property....(nor have I received my electric bill), but I know it will be substantially less than my equivalent gasoline bill! (Not that I care, but not 1 person has criticized this car...IT IS TRULY REMARKABLE)! Those waiting will very much enjoy!!!

I got the warning this morning "Car Needs Service, Power Reduced", but went away when I started driving. There was nothing about a Software Update.

I just checked (Saturday 10:45PM in California), there is no Update waiting for me either.

Assuming that the warning this morning was about a failed download, will it try and download again?

Mohan

Here's a comprehensive collection of screenshots, detailing the new features:
http://www.teslamotorsclub.com/showthread.php/10284-Model-S-Software-Fir...

Thanks, Volker. However it should be p. 29.
Thanks, Schlermie.

I've updated the Wiki with all the new changes: http://www.teslamotorsclub.com/showwiki.php?title=Model+S+software+firmw...

This is blowing my mind . . .

My Lexus is no smarter than it was 4 years ago. The Model S keeps getting better all the time.

Last night coming home from an Xmas party, I noticed two really odd things on my drivers-side display, which I have never seen before. In the 're-gen' monitor, there was a phantom orange broken line that started at 20 khw, and moved slowly to 40 khw, before disappearing (it made no sense what it's purpose would be, other than an error).

Later at the bottom of the display (just above where time, temp, etc is) all the sudden a bunch of strange looking tiny symbols appeared (looked almost Arabic or Thai).

I haven't received the new software upgrade yet, however, the timing is strange.

@Tikiman - is the orange line the signal that regen is disabled? (and slowly coming back?) Was it super-cold or the car completely charged?

@Nick, I did charge it at the 'max' setting to 270, because I was taking a long trip (which was the first time I have done this). Although, I didn't top it off, to the full 300, I am surprised that it would not allow for re-gen when I still had 20 miles of battery life uncharged?

Yesterday morning I, too, got the warning "Car Needs Service", but it went away when I put it in gear. Still no software update as of Noon PT today. I do have poor 3G coverage in the garage (1 or 2 bars), but phone and browser still function.

@Tikiman - definitely sounds like the regen thing, though surprised you didn't notice it.

@Mike6, I love your description! When I got the first software update (a few weeks ago), I just scheduled it at 2am and didn't check on it. I also got the "Car needs service" warning yesterday, but so far no software update notice, and mine is still on version 1.15.14
it is great that our Model S will improve over time. Yeah, I always thought it is more a computer than a car, and feel it is finally a car of the future (here now!)

DouglasR, thanks for the correction. I wonder how that happened, but I certainly did not intend to send people to the wrong page... Now that the PDF is available, that's of course much better in many ways.

Volker, I believe that the page breaks on many threads can change as new posts are added. Your link was probably accurate when you posted it.

@Tikiman - I had previously spoken to a service person about the orange broken line. It has to do with the temperature of the battery pack and will keep your car from accelerating or regenerating past the broken line (I haven't seen it on the acceleration side yet). They told me it was normal and not to worry about it. The line will go away when the car reaches an appropriate temperature for standard operation (and it has gone away in my case). It happens to me every night that I leave work when the car has been sitting in the cold temp's all day.

David M;
Someone from TM said that when you first get your car it's the worst it will ever be.

@jamesgx, thanks for that post, I saw the jagged yellow line and regen seemed to be reduced, now I know the answer as to why! Thanks again!!

Still no upgrade notice yet, however, now my car says..."Service 12 Volt Battery".

It would really be nice if Tesla would update (and expand) the on-line .pdf owner's manual with each software upgrade. For example, my current owner's manual (accessable under My Tesla) has only a single paragraph on p 17 relating to the Energy App/Screen, and there appear to be some significant changes to this app with the newest software.

Oh, BTW... I was able to fix the other issue with my front display, by rebooting it via the two upper steering-wheel buttons pushed simultaneously (similar to rebooting the touch-screen, just one step up).


X Deutschland Site Besuchen