Forums

Join The Community
RegisterLogin

Valentine One Radar Locator.

Has any one been able to install a V1 Radar Locator and get the signals received through the MS glass? Several have told me that some coating on the MS glass prevents signals from being received by the locator.

MS TBD = Delivered December 2013.

I've got mine mounted above the rear view mirror on the plastic housing. I removed the suction cups from the mounts and used Velcro to mount it to the plastic housing.

This allows the front locater to receive a signal, although slightly degraded, through the housing because there is no windshield coating on that section of the windshield.

It does work but not as well as I've been used to in my previous cars. Even with the reduced range it's still better than other most other detectors standard range.

Mortgagebruce, could you post a picture? I'm likely going to try that as well and am curious how you ran the power cord. Thanks

I had it hard wired. I'll do a picture tomorrow.

Mortgagebruce: Have you been able to gage the reception from other directions? The biggest feature of this detector has been its ability show where the signal is coming from. In my opinion, this is one of the best detectors made, and has saved me many a time. Perhaps the widow coating is going to diminish signal input from the sides or rear.

I mounted mine below the mirror and got the front of the detector as close as possible to the glass. The windshield is more dramatically slanted for aerodynamics.

I placed it low enough so that the detector might pick up signals through the rear window too.

The detector isn't as sensitive with the coated windshield, but it still works. You just don't get the early signals like the V1 was made famous for.

Mortgagebruce, TeslaTEK, Captain_Zip:

Have you gentlemen seen and/or considered the BlendMount as an attachment device for the V1? Perhaps it would hold the unit too far from the glass. Actually, the suction cups do place the front top of the V1 against the glass. Here is the link on the BlendMount:

http://store.blendmount.com/blendmount-radar-detector-mount-for-valentin...

I use the iphone app for the v1 on occasion and can confirm that all signals pass through, x, k, ka-low, ka-mid, ka-high, laser, front and back for all ... and I have not noticed any range degradation. It is mounted (hardwired) top of windshield just left off mirror. I have not seen any difference compared to when it was in my other car. I understand that our friends across the pond may have a need for ku and without a source to test against here, I can't confirm ku passes through.

Wow, that Blendmount mounting system is slick!

I see folks saying they've got it "hardwired", and there are some wiring harnesses on the Blendmount site. Anyone know if there is a ready-to-use wiring harness for the Model S? I've seen some reports of fabrication of headers, how to do in-line fuses, etc, but I'm not really up for a project.

Here are a couple of links to how I set mine up. I know the pics suck but you can at least get an idea.

I had mine hardwired at Best Buy. It cost $45 and only took about an hour. I had them do my Range Rover and Jaguar and they've always done a great job and this is easy for someone who knows what they're doing.

http://www.dollarsandhomes.com/files/2013/10/v1a.jpg
http://www.dollarsandhomes.com/files/2013/10/v1b.jpg

Oh, I've had zero issues with signal from the sides or the rear.

We may have to abandon the use of our favorite radar detector, as BlendMount got a note from Valentine One that the metallic film on the windshield kills laser reception and about 90% of radar range. Too bad, I've used this detector for many years.


X Deutschland Site Besuchen