Forums

Join The Community
RegisterLogin

Another wifi question

I'd not cared much whether I had wifi connection with the car at home until I read here that onboard map updates might be coming only to those who have it. My car has always sensed my network but the signal was never strong enough to link up. So I put a booster in the garage. I know it works because my iPad won't connect in the garage when the booster is off, but gets all the bars and connects happily when it's on. Not so the car. Stays at a simple dot in the connectivity icon and won't join.

I have an Airport Extreme, latest version, and the booster is an airport express that I've had a couple of years or more. I called Tesla service and he really had nothing much to offer. Said the "frequency" of the newest Airport is grokked by the car (don't know the right terminology, being a borderline idiot regarding electronica.) 8 something something 11. It's also the case that the car picks up wifi if I'm close outside, say, of a Starbucks.

Any ideas? Would a newer airport "booster" express make a difference? It's definitely reading the main router, but it seems it makes no difference to the car.

I have a similar set-up, although I use two Airport Extremes, so I can vouch that it should should work. Can you tell me about the config for the Airport Express and it is the kind that plus into the wall or one of the newer ones that looks like a white AppleTV?

O

Just get an Airport Express ($99) and plug it in. It will see the AirPort Extreme and automatically latch onto that signal and settings. Then unplug it and relocate it to a plug near the car.

Next go into the car and touch the Wi-Fi again to make it search for the house router again. It will lock into the closer router and disregard the distinct one with the same name.

I've been extremely frustrated with this.

Have a new Airport Extreme which Tesla will latch onto. Tried to use an older first generation Airport Extreme in the garage, and all it sees is 1 dot and most of the time will not connect.

I'm gonna try a new Airport Express tomorrow and see if that will do any better.

@SeattleSid - the '8' and '11' that they referred to is probably the WiFi channel (the transmit/receive frequency). Difficult to troubleshoot this via the forum, but you should be able to use the Airport Utility on your iPad to see/configure the route and check which channel it is on. Try swapping it to a different channel. Maybe the car electronics have more interference with one frequency vs the other (think static on an AM radio).

Omarsultan: it's the newer kind that looks like Apple TV.

TeslaMD: I think that's what I've done; I got an AIrport Express, linked it to the Extreme, took it to the garage, and plugged it in. As I wrote, my iPad picks up the signal from the Express in the garage, with full bars. The car, though, with or without the Express (green light solid) near it, remains at a dot instead of bars, and won't link up.

So maybe the car is "trained" to link up to the original one, with the one bar. I wonder if there is a "forget this network" option, which you could do and then try to reconnect to the stronger signal. Yeah, it's hard to trouble shoot this kind of stuff.

I believe that "8 something something 11" refers to "802.11", which is the IEEE standard for wireless networking:
http://en.wikipedia.org/wiki/IEEE_802.11

If so, worrying about it is irrelevant to this discussion, as all wireless communication you are considering will undoubtedly use one 802.11 standard or another (e.g., 802.11a)

Regarding @BoxcarX's comment about "Forget this network", consider this statement from the Tesla Owner's Manual:

"Once you have connected to a network, Model S auto-connects whenever the network is within range. If more than one previously connected network is within range, Model S connects to the one most recently used."

@SeattleSid. You only have to download the maps once a year. Why don't you drive to the nearest Starbucks. I heard they have a few in Seattle. Park outside. Hook onto the free Starbucks signal. Go buy yourself a vente latte. Relax for a few minutes. By the the time you are done drinking your coffee and gawking at the the sexy 20 year old females walking by your uploads should be done. Alternatively hire a young kid to troubleshoot your router extenders.

Hmm... so if that's the case, then move the car back out of the garage a bit so it is definitely out of range of the original wifi router and only in range of the booster. With any luck, the car will connect to the closer one and remember that as the most recently used connection point. Sorry, I'd experiment, but I don't have my S85 yet. Hey, maybe you can bring it over here in Chicago and we can try to recreate the problem in my garage :)

@SeattleSid, Nick is very savvy. So he probably correct about his comment that the Tesla service guy said 8 and 11 because those are in fact channels on the router. But it could also be the Tesla service guy was just stating the obvious and what he said was 802.11

Omarsultan, or someone that is familiar with Airport Express and Extreme. Could the subnets between Sid's two devices be the same?

You might have a configuration conflict with your settings. The good news this cost nothing to try. I bet you already know about IP addresses. I don’t know what addresses Airport Express or Extreme use. Maybe someone here knows if the Express and Extreme will try to use the same subnet? And they could also be using the same channel like Nick mentioned.

Most router manufacturers use the more common subnet address 192.168.0.1 for the gateway address on a router. Some use 192.168.1.1. Your booster needs to be a different address than your main router’s address, so they are not offering the same string of addresses to your car or ipad. So, you will want to change the third number called an octet. Here’s an example to change it to - 192.168.2.1 or even 192.168.3.1 will work. Its not that it must be different, but different increases your chances of success.

You go into the booster’s configuration settings to change this. While you are in there, you might want to change the channel the Extreme is using. What channel? Well, it needs to be a different channel than your Express is using. And you don’t know what its using until you login to the main router and see what its on. After you make any changes, you need to save the setting changes and restart the Express and Extreme.

Good rule of thumb when you have network connection issues. Turn all the equipment off. Cable modem, routers, boosters, sometimes even the computer. Start turning the equipment back on from the component closest to the outside of your home or the street, to the inside of your home closest to the computer (or car). Like 1. cable modem, 2. router/Express, 3. booster or extender/Extreme, 4. computer. (This might be a good time to reboot the main console on the Model S too.) Give each component about 30 seconds to finish the boot up. This simple process will very often fix Internet connections.

@seattlesid, If after a week or two of trouble shooting it and it still does not work, I can come over and trouble shoot it for you (assuming you are Puget sound area). I don't have the exact wifi equipment you have but I have experience with it. my email is solute (at) ymail (dot) com

If the tech was talking about channels he would have said, 3, 6, or 11 - the only non-interfering channels. 8 and 11 aren't channels anybody would normally talk about. 802.11 is the more likely thing he was talking about and the numbers don't matter.

iPads also tend to connect to not very strong signals (one bar when you first connect) and then display full strong signal after they connect. Your booster connection may be too weak for the Tesla but strong enough for your iPad.

This is probably more about signal strength. Either your booster is too far away from your main router; or your booster is too far away from the car. Or I guess your car is still trying to connect to the weak main router signal and ignoring your booster.

Can you change the network name on the booster? That would tell you if the car is connecting to the booster or the main router.

I have tried with different options. My MS still does not connect and even if it connects it quickly moves to 3G though the 3G signal is very weak in my garage.

And when my MS does connect to the Wifi (albeit briefly) I see a strong signal. SC was not able to help and the ranger who came home saw that his phone was able to connect easily but not the MS. He didn't know why.

I am using an older Airport Express connected to a power line ethernet adapter. The AE is set to 802.11 n (802.11 b/g compatible). Sometimes the Tesla connects to the AE and sometimes it connects to my Time Capsule which is further away and is also set to b/g compatible.

The signal level is only 1 bar (sometimes 2) but the data rate is usually around 32 M b/s shown in the Airport Utility. Note: as far as I can tell, the WiFi isn't used when the Tesla is in sleep mode.

When I put the AE in the garage I got all the bars. I think I will move the AE to the garage when doing an update and disable sleep mode.

As far as the "just drive to Starbucks" option, from my experience Tesla updates are not like the updates you get on a computer or phone where you can grab the update whenever you want. Tesla pushes out the updates on their schedule to cars in batches and only to those where Tesla sees Wi-Fi on your end. The odds that Tesla would be ready to send to your VIN at the same time you were at Starbucks would be extremely rare. That's why people want to prepare in advance so their car is ready to receive when the update is sent to their VIN.

First, the suggestion to turn off all other Wifi equipment is a good one to test things out because it could be that the Model S is a different vintage of 802.11 and your airport express may not be able to handle the difference. Second it may be that your extender is operating on a different channel and the Model S can't switch. For example, if your Wifi network is using channel 11 and the model S is on channel 11, the extender may use 11 to communicate with the router but channel 6 to connect devices to itself. If the model S is stuck on 11 you will see what you are seeing now. You may have to manually set the channels for your devices. Find out what the router is using and what the extender is using and swap the channels around.

Third, 95% of the complaints about Wifi connectivity involve Apple products. That may mean the 95% of the owners use Apple equipment or ... well you fill in the rest.

So, to answer a few of the questions:

1) "802.11"(followed by a letter) is a set of protocols for wireless networking. Discussing that is getting more into the weeds that we need, but @SeattleSid has new enough gear that is should not be an issue
2) Wireless does not "pair" like bluetooth so you do not have to "forget an access point" If he has successfully extended his network, the endpoint (car, phone, iPad) will latch on to the strongest signal, although sometimes this will take a few seconds
3) Subnets should not be an issue. The car uses a protocol called DHCP to ask for an IP address from the the access point, so things are always in sync. You manually set and address on some devices, which will hose things, but I have not seen that option exposed on the MS.
4) Channels: there could be channel conflict, but that would result in poor bandwidth or intermittent connections, not "no connection". Also the access point is smart enough to hunt for an open channel, so unless you live in an with high density (think downtown apartment building), it should not be an issue. Yes, some channels are naturally faster, but should not be an issues in this case as we are not talking about huge bandwidth requirements.

In terms of next steps, log into the Airport Express with the Airport Utility and go the the "Wireless" Tab

Photo & Video Sharing by SmugMug

And make sure the field pointed to by the red arrow says "Extend a network" and the fields pointed to by the orange arrows" exactly match the details of your existing Airport Extreme.

The airport will likely want to reboot at this point. Next, so to the turn, sit in it to turn it on and tap the wifi symbol on the top and take a pic or tell us what you see:

Photo & Video Sharing by SmugMug

Ideally, it should be connected to your network. If the car is connected to some other network, then select yours again. If it does not show your network or does not connect to your network when you tap you network name, try the next step:

Tap on "Wifi Settings" at the bottom of this list at the:

Photo & Video Sharing by SmugMug

If your network was not showing up in the previous list, add it here. If it was showing up, select it, select forget this network, then add it back in--make sure you use the same security type and don't fat-finger the password.

See if any of this helps, then report back.

Good, luck,

O

See, this is why I love this forum. So many smart and generous people. (I also like the wit and humor!)

I really appreciate everyone pitching in to help out, and even offer to come by and have a look. (I live in Mukilteo, Salute.)

I'll try the various things and report back. For one thing, I reset the Airport Express and retried to link it to the Extreme, and have discovered some weirdness on the Airport Utility: it keeps saying my Extreme isn't linked even though I'm on the home network and wifi is working fine. Gonna try it on my wife's iMac instead of my Macbook.

And I still love Apple products.

Omarsultan, if I go into iPhone / settings / wifi and tap on the "i" with a circle around it, there is an option to "Forget this Network." I've use that before when I'm in the range of multiple networks and the iPhone somehow always connects to the one I don't want. After tapping on that, the iPhone never connects back to that network unless I deliberately and manually connect to it again. i do see a "forget network" option in your last screen shot too, so I'm wondering if that functions similarly.

Just had an issue with my old Express extender in the garage. Here is what I did to resolve:
1. Using Airport Utility on your main computer restart the Base Station,
2. On the Tesla, delete the Network of your Airport.
3. Once the Airports are back on, do a restart of your Tesla system which will reinitialize the WiFi system on the Tesla
4. Open the WiFi window on the Tesla and select your network as broadcast by the Airport.

Worked for me.

@Boxcar:

You are correct in your interpretation that your phone will delete the credentials for connection that network. I do this after I stay at a hotel or go to a conference and have connected to their wifi.

What I meant is that the wireless endpoint does not connect to a specific access point, but to a network. In Sid's case, if things are set up correctly on his car, it will automatically find and connect to the Airport Express in his garage since its the "same network" being served up by his Airport Extreme--his car is not linked specifically to the Airport Extreme, it will happily connect to any access point advertising the appropriate network. Does that make sense?

O

@SeattleSid:

One more thing, since you have a Mac laptop handy. If you hold down the option key while clicking on the wifi symbol on your menubar, it will throw up a bunch of diagnostic info.

Photo & Video Sharing by SmugMug

Can you do the following:

1) Standing next to you Airport Extreme and get a screen grab or pic of the dig info
2) Turn off wifi on your laptop and go to your garage, then turn your wifi back on
3) Grab another screen grab/pic of the dig info standing next to your Airport Express
4) Share the pics

Thx

O

OK
I tried all the above but NO! So try to picture this. I stood outside the house were the router is and with my arms outstretched and mouth open looking up into the sunlight, skipped on one leg over to the garage hoping to carry the signal to TESSIE, but NO! Was so frustrated that drove my wife's BMW over a cliff by the house and now I feel much better. Happy Saturday all!

Or Sunday in Beijing

@Rheumboy you made me laugh!

Salute;
Is your email really 'solute'? Why?

My email is solute. It was a late night and I needed a yahoo email address for some yahoo stuff. Thought I typed salute but ended up typing solute. They ask for the password to be typed twice but not the email address. It was not important enough to change to another email name. I use the email address now for stuff that is not work or family.

For lazy Apple users and the 98% who are not SuperGeeks, consider this App to measure WiFi Strength
https://itunes.apple.com/us/app/wifi-explorer/id494803304?mt=12

Also be sure to check bandwidth - I use SpeedTest.net -- I find in my bedroom I get greater bandwidth with my 2.4GHz network than my 5GHz network.

Anyone who has Airports that do not support 802.11ac (i.e. older than about June 2013), will likely be amazed at the signal strength improvements with the current Apple products.

Regarding AirPort Expresses (at least the older style that does not look like an AppleTV in shape) - these are not real easy to adjust some settings with AirPort Utility. If you are having issues, just reset the beast and start over.

Do not underestimate the importance of putting the Base Station up high in a room. My Base Station is in the extreme NE corner of our house. The master bedroom is in the SW corner. Merely moving the Base Station from a middle shelf to the top if a book case gave me one more "bar" in my signal strength. That resulted in a 20% bandwidth increase.

Do not forget PowerLine systems as an option to get WiFi to distant parts of your house. Functionally these are like an Ethernet connection. If you want to run Ethernet cables, MonoPrice.com has reasonable prices - I bought a 100 foot cable for a fraction of the HomeDepot 15 foot cable price.

Ah, a permanent typo. My sympathies.

So, got the newer Airport (Apple TV type) and stored the old one. Poor sig in garage(detached) - so all I need do is take the older one to the closest corner of the house. But, do I need to connect it via Ethernet to the Base station?
According to the Genius dat's da way ta do it.


X Deutschland Site Besuchen