Join The Community

Bugs in 5.9

After updating while driving the car kept trying to adjust suspensions. I felt like I was driving on high or very high and some times it released air like a truck. I rebooted the car after stopping and it seem to have gone away.

Rdio sometimes start to play a new song but is only able to play for one sec or so before the song stops and it try to buffer again. Should probably not play the song before it has at least 10 sec of music.

I think(not sure) that the saved preference for steering was lost after the update. I think I had it set to Comfort and it shifted to Normal.

P28972 - Updated from 5.8 to 5.9 without any reboot.

My "bug" occurred during the install. It failed last night, leaving battery monitoring in a bad state. Rated range continuously bounced from 350+ to 0 to 20+ miles, back and forth. Strange error messages on battery temperature, and then the charge port would no longer open by any means. Despite all of this, I drove it 80 miles with no issues. SC picked it up and reinstalled 5.9 from scratch. Nice job on 5 hour turn-around so I could get home. 5.9 itself seems great with no issues so far.

Slacker not playing is not a bug, its typical and annoying.

@Super-Popular - I don't have problems with slacker not playing. Do you have a good cellular signal? I'm assuming you did a re-boot after your update.

@BBruce - Sometimes, if there is a corrupted update, ownership can arrange to send out a new one. If it gets hung up then the local service center has to uninstall the old update to make your car capable of taking the new update.

This is why I never do updates in the morning when I have to be somewhere. Early adopter experience. We used to get major updates every few weeks.

Noticed that car started charging after completing the update and completely ignored the scheduled charging. Luckily, I was in the car watching our first ever update and stopped the charging. Otherwise, would have ended up paying for peak electricity rate for the charge!

New behavior with 5.9: After getting back into the car after parking, a slacker tune that was previously playing will then continue for a short while but then quit and go on to the next.

Have not rebooted.

@larryh, AFAIK it has always been such. It buffers ahead, but if the car is off for a significant amount of time (say long enough to go into sleep mode? total guess) it can only play what is buffered of that particular song and then says "ut-oh, I'd better go get new content".

I've had my Model S for two weeks. I received the 5.9 update the other day. My screen has spontaneously rebooted 3 times since then while I was driving. That had never happened to me prior to the update.

Okay, please keep these issues posted to see if there's a trend we can detect.

May I recommend to make this thread Private so that we're sure to get bugs from real owners only? Thanks!

A brand-new owner reported a reboot on his first day, today.

Yesterday my main display rebooted while driving. Car drove normally through the reboot. After reboot, gps forgot the destination I had selected and started directing me back home.
Since I was going to a place I had never gone and didn't immediately realize what was going on, I pulled over and followed my iPhone GPS instead. Realized later that the car wants to go home.

Wonder if anyone else has had this happen to them.

After update, main computer spontaneously rebooted twice during a 2 hour trip. Hasn't happened since after several hours of driving.

I may be the new owner Brian H was referring to. I picked up my new S on Saturday morning and it rebooted three times while driving throughout the day. Put in a call Saturday night to the main Tesla number, they said they'd forward the issue to the Highland Park (IL) SC and that I'd hear back Monday.

No spontaneous reboots here under 5.9.

Remote Access (I posted this on TMC as well)

Here is my issue: I updated to v5.9 (1.51.88) early yesterday morning, and ever since I can only connect with the iPhone remote app if I do it in the first minute or so of leaving the car. After that, it will try to connect for a long time and then display "A Connection to the Vehicle Could Not Be Made." Retry does not work. Here has been my troubleshooting so far:

1. Reboot main screen with Remote Access on.
2. Reboot main screen with Remote Access off.
3. Reboot main screen with the display Energy Saving mode on.
4. Reboot main screen with the display Energy Saving mode off.
5. Try with both car and phone on WiFi.
6. Try with both car and phone on cell service.
7. Completely delete the Tesla app from my iPhone and reinstall/re-login.
8. Try my wife's iPhone app.

Nothing has worked. Anyone have any suggestions? I will call Tesla tomorrow if I can't get it to work today.



Also, I have turned the Energy Saving mode off, and it still doesn't connect.

I'm having a lot of issues with 5.9

I hopped in the car today and the media app said "check antenna" where the Sirius track information usually is. Then I tried pairing my phone, this was successful but then I tried selecting it from the media sources menu and that's when things went downhill. The menu with the audio options disappeared and was replaced with a "trying to reconnect" (or similar) message and I lost the ability to change the audio source on the touch screen. When I rebooted i was greeted with a red bar that says "Navigation needs service". A reboot removed that. I've now deleted all of my devices but still have no luck with the bluetooth audio.

I'll head to service tomorrow morning.

@tesla_mahedy. Of course, I'm sorry for your troubles with 5.9 but I'll definitely wait to install until all of this shakes out.

no issues here.

knock on wood Noel

I got my car yesterday and it had the 5.9 update already and if the black screen with the "T" in the middle is the reboot screen, I too have had that happen to me 3-4 times today. Also, I was able to pair up my phone yesterday. Then during the day when I got back into the car, the car couldn't pair up with my phone. It was listed on the phone screen, but it wouldn't connect.

I've had my car for 2.5 weeks and installed 5.9 two days ago. Only thing I've noticed is my efficiency has tanked. It was bad to begin with in this cold weather (averaged about 400-450 Wh/mi) but the first day of the update I spiked to over 900Wh/mi for quite a few miles and have averaged 550+ since the update. The weather is actually warmer now than before the update (45 degrees instead of 35) and my driving habits are the same. I don't know what's going on.

Picked up my p85 on 3/29 and had 5.9 installed while I toured the factory. Definitely rebooted once while I was driving home. I reported this on a separate thread. Today was day 1 with the car and he initial bugs that I reported seem to have worked out. There is no more XM (had random cm channels active on the drive home from Fremont). Slacker is up and running. Hill assist works and air suspension is active as described. Radio reception appears to have improved.


It was a long update. Is there any chance that some people interrupted the update? Did everyone get a message that the update was complete? There were times that I thought it was done because the car was quiet and dark for a while. Then several minutes later it would get busy doing its thing again. I'm curious whether that is a possibility and how it would impact the update.

Has anyone had any new updates pushed to them or had any other remote diagnostics done when they called ownership?

@El Capitan Service did the update for me on Saturday when I had them fix the fact that my pano roof was opening and closing crookedly.

Have the lambs stopped screaming 5.9?

I picked my car 85 on Friday and had 5.9 installed, since that it has rebooted 4-5 times on me while driving. In noticed every time Navigation was lagging and then the console reboots but the cars keeps running and after the reboot everything comes back to same as before the reboot.

I updated to 5.9 and had to re-configure a number of settings on my car and re-enter my Slacker login and password. I have not had any reboots or other issues though the first time I went to use the nav it tried to navigate me to home, though since then it has been fine.

No issues with 5.9 after using it for the last 3 days, including a long road trip yesterday.
No reboots, no bluetooth problems, nothing.

I must say: I love it!
The auto-lowering, the Rdio support, the improved browser, the hild hold assist, and several little details, it's all great.

Would be good to know which % of users is affected, but unfortunately such things are virtually impossible to find out.

My car was delivered Friday with 5.8.7 and updated to 5.9 overnight.

I didn't reboot - is this normal practice? Everything just seems to work just fine. Haven't needed to reboot the car once yet...

Rdio is a bit stop/start, but to be honest we don't have the greatest signal-strength in Brussels due to local regulations that force the telco's to keep the signal strength as low as possible.

Shall we make book on how soon 5.9.1 comes out?

X Deutschland Site Besuchen