Forums

Join The Community
RegisterLogin

Can the Model S battery demagnetize a bike odometer

A real insignificant problem but a relevant question. I transported my bike 30 miles each way in the back of my tesla for a service. I rode just prior to the service with a fully functional bike odometer but when a rode the next day the odometer was non functional. I took it back to a closer bike store and expected it to be a battery issue but it turned out the magnet on the wheel quit functioning. The bike store guy could not understand it but replacing the magnet was a quick fix. The second day transport was in an ICE vehicle. The good news is a bike does fit very easily in the trunk with the seats down but is it possible that the battery can demagnetize a small magnet. Probably coincidence but appreciate input.

The battery cannot demagnatize the odometer, however the electric motor and inverter maybe? Battery is DC but an electric field is created from the inverter and electric motor. I would guess it is small a few feet away but I could be wrong.

It might have had something to do with the magnets in the shelf support. (They are located on the rails near the back.)

I have not experienced a demagnetizing problem. I have only put my bike in our Model S a handful of times (4-5). I, too, find it fits just perfectly on its side, with the front wheel off, and the 60% back seat down. Now my magnet is on a front-wheel spoke, and I put the wheel behind the driver's seat.

Where do you put your wheel with the magnet? Have you tried behind the front seat, or even in the frunk?

Loaded it into the back with front wheel facing the back. I dont take off my wheel. Fits well with both back seats down. Will try again. all it can cost me is another magnet. If it does demagnetize I suppose the easy fix may be to take off the wheel and put it behind the driver seat or in the frunk

Anybody had demagnetized credit cards after having them in the trunk?

Dont usually leave mine in the trunk. Anyone want to try it and report back?

If you have a compass you can start away from the Tesla trunk and move towards the trunk looking at the needle. While getting close to the trunk and moving the compass around the trunk if the needle deviates from North then there is a magnetic field there. Just won't know the strength. If you don't get anything from this then have someone sit in the back seat and start driving. If the needle deviates then you know you have a magnetic fields from the electric motor and/or inverter that grows as the speed increases.

There are magnets under the parcel shelf support rail on both sides of the car. Maybe you passed over, or leaned your wheel with odometer magnet against one of these. The two magnets could have had sustained contact this way, enough to "mess" with your odo like that.

doubt it has anything to do with the car battery

I don't think it's possible to demagnetize a permanent magnet. Maybe wrong, but ...

First of all it is important to understand that batteries do not generate magnetic fields. Electric currents do.

Electric currents come in two flavors: AC and DC. A DC current will generate a stable magnetic field, which is unlikely to demagnetize a magnet. According to some googled 'knowledge', the fluctuating magnetic field that an AC current (from the AC motor) generates is easier to demagnetize a magnet. So if the magnet was demagnetized, it was not the battery, but the motor that did it.

I still find it hard to believe, since a permanent magnet for a bicycle computer is pretty strong compared to eg a credit card. I would expect rear seat passengers to suffer from useless credit cards after a ride in the Model S, but I have not heard of such a thing.

Perhaps the old magnet was barely strong enough to trigger the reed contact in the bicycle computer's sensor and loading/offloading of the bike misaligned the magnet just enough for the computer to stop working. Finding that correct position may have been an impossible task for which the bike mechanic just didn't have the patience.

May have been coincidence but the magnet was definitely dead. The bike tech moved it around and even placed it directly on the sensor and no life. The new magnet works fine and for $7.00 was an easy fix. I will try the tests with the magnets as suggested above when I get a chance. If there is something in the back such as the storage shelf that is doing it I will either need to take the front wheel off when transporting the bike or keep a good stock of magnets.

I assume you have a quick-release skewer, but if not, thanks very quick and easy wheel removal. I filed my "lawyer tabs" flat, too.

No big deal taking off the wheel. Change flats all too often. Just easier if I can push down the back seats, throw the bike in and go.

When replacing the wheel, note the lugnuts require 129 ft-lbs torquing.


X Deutschland Site Besuchen