Forums

Join The Community
RegisterLogin

Replacing the Alpine nav / music system

Hi all,

I have a Tesla 2.5. I love everything about it except the Alpine music and Nav system. Frankly, it's unintuitive, the UI completely changes between Nav and music/radio, and it has pretty poor radio reception.

Has anyone replaced their head unit? Is it difficult? Can any garage/car audio place do it? Does anyone have any recommendations for a double height music and nav system?

Many thanks

Robert

@NoPetrol

Is there a decent aftermarket head unit available for the Roadster? I cannot find anything that is a worthwhile upgrade.

@Smop call the guys in LA who retrofit high end cars/Teslas. I like Kenwood as it uses Garmin Navi.

some install the new Parrot

openvehicles.com is integrating it's roadster mobile-phone app in it

You get simmilar functionality as in the model s touchscreen then!

If you modify any of the electrical components of the car without their consent! they website electrical draw and attractive disturbance as their primary fear . . . . . . . . .

I am using pioneer with Bose amp, delivering high performance. Also paired my iPhone as well having no issues of echo and reverberation.

Is there a reasonable upgraded go device available for the Nissan ? I cannot discover anything that is a beneficial update.. . .

[url=http://www.surfersrentacar.com.au/]car rent surfers paradise[/url]

My radio *finally* doesn't change levels. They replaced the power amp with a special order amp that has the noise cancellation disabled. I'm happy with the sound now..

But not the USB connection, the UI, etc...

Also followup...
When I complained to Alpine about how bad the UI is, I pointed out that the Nav UI is much better than the audio UI. She told me that is because they were designed by two different teams what don't interact. No surprise there.

They said there were no plans to fix it as it is a 'mature' device. Read that as they are not wanting to support it, probably in favor of the next versions.

Does anyone else have difficulty scrolling around the map in the Nav UI? I find that the drag gesture very rarely works: when I try it it just interprets it as a click gesture instead, and places a pointer where I wanted to start dragging.

Wish I had found this thread previously. I got Tesla UK to change my Alpine Unit out once already but still have the same bugbears - random volume variation, poor phone performance, dodgy response to swipe on the Nav UI - and now I see I am not alone.

Scotty2541 - who did you get to sort the amp? I will pass on your comment to the guys coming to do my annual service tomorrow and see what they say!

NAQ88: Sorry I just saw this question.
The guys in Chicago special ordered an amp for me, and Lawrence put it in.

I had to change out my Alpine myself. Just did it two weeks ago. I like this one better. Kenwood DNX 690. I had to adapt a small regulator to get the back up camera to work.

It picks up distance radio stations that my Toyota and Acura can, but the Alpine couldn't.


X Deutschland Site Besuchen