Join The Community

Rev 4.2 Downloaded Early Sunday

Well, we now are running rev 4.2
So far the changes have not been obvious in driving. Will update as we discover interesting differences from 4.0. Love to hear from those that see or know what we might be looking for in the latest update. It does feel really cool that all this happens while I and the car are " sleeping". VIN 2859, 85std with most options

@William9, my update was from 1.15.14 to 1.19.42 (4.2). I did start out watching the update, and as reported elsewhere, the car goes through a number of gyrations, clicking, whirring, flashing headlights and rebooting of the screens. After about 20 minutes, the car went completely dark, and remained that way for about 10 minutes. I was sitting in my cold garage in the cold car, in the dark... so I gave up after about 10 minutes and went back in the house. I went back and checked on it maybe a half hour later, and it was rebooted and updated. So, It seems to have taken somewhere between 30 minutes and an hour.

Just another interesting observation... while I was sitting in the car watching the update, the screens reboot several times. At one point, I noticed that the clock on the dash screen (in front of the driver) was different than the clock on the center screen. In fact, the date was also wrong. This was last night (1/24), at about 5:00pm CT, and the dash was indicating that it was Monday January 26th, and the time was 4:36pm. So, I don't know where it was getting that date, but January 26 is not on a Monday this year. After the update was finished, the clocks were once again in sync, but it was a bit disconcerting to see it reporting a time and date that were completely different, and not even correct for the current year.

So glad others are sitting in their cars too. I thought we were theo nly crazy ones! Don't get me wrong, I LOVE my car but we too are obsessing over little bugs and hoping to get the 4.2 update (received car with 4.1)...Lots of little bugs...

@mkh1473 - thanks for the suggestion to email, but so far it didn't work for me (I still have 1.15.14). Instead I got back a canned, non-answer as follows:

"Thank you for contacting Tesla Motors, I hope you are enjoying your new car.

Our process for new software releases is to start slow and ramp up to include more and more cars over the course of a few weeks. The sequence and cadence at which customers receive each new release can be based on vehicle region, vehicle equipment, and many other factors. Tesla's goal is for all Model S customers is to receive new software within a few weeks of its first distribution.

I would anticipate complete rollout to be implemented sometime in the near future, so expect it soon. Congratulations again on your Model S!"

I guess this is another example of inconsistent information from Tesla depending on who you ask. :-(

Your car was briefly reporting on a parallel universe. Full access will be available in release 100.0 -- or thereabouts. It will be called the Gay Deceiver update.

I pas pushed the option to update to 4.2 and I tried to do that last night by scheduling it at 2 AM as the update was set to when it came to me. This morning, I was still on 4.1. My previous update from 4.0 to 4.1 overnight went without a hitch. The best that I could figure is that I still has sleep mode active on my car and it went into that and never started the update at 2 AM as scheduled. Did anyone else have this happen to them? I guess I'll try again tonight and leave sleep mode OFF.

Interesting! Sounds reasonable. Let us know if it works.

@Jim2855 Same experience. Was set to install at 2 AM this morning & did not. I wondered about the sleep function also. I did the install now option about 20 minutes ago...will post when upadte is complete.

<45 minutes to go from 4.1 to 4.2

This is still early, as I have only used 4.2 for one day, but I twice I had issues with the door handles today.

The first, I walked up to the car and it didn't present the door handles. Pushing on them didn't help either (which has always worked before), and I was fumbling for the key fob and they finally presented before I could try the fob (about 10s after I walked up to the car). The car also took a long time to go to the "ready" state, as I had to press and release the brake several times to get it out of "Car off", and I had never seen that before.

The second time, I got out of the car, opened the back door to get my backpack out, and then closed that door with the driver's front door still open. That door retracted but all the others didn't. I walked away, and the car never locked/retracted the handles. So, I pressed the key fob and nothing happened besides flashing the lights. I tried pressing just the LR door, and it wouldn't extend the handle. I closed/reopened several times, tried the fob several times and it didn't change. Finally, about the 4th time when I used the fob it retracted the other door handles.

So, on a very small sample size, I have had far more troubles with door handles with 4.2 in one day than I had the 2.5 weeks prior on 4.1.

I picked up my P85 with 4.1 installed on 12/31/12.
Yesterday I was notified 4.2 is ready to install.
I just clicked the install button and it took about 30 min to complete.

Not sure of any big improvements yet, but I never really had most of the issues I've read about. I did have the odd windshield wiper which would wipe just one time occasionally when I'd open the driver door. And there was occasionally some glitchi-ness with the door handles refusing to present themselves. But it was mostly minor..

Taking my son o the track tomorrow. I'll report any differences I notice.

P.s. anyone in NorCal start a tesla car club yet? Let's meet up at Infineon and get a little track time?!

After 4.2 installed the door handles are behaving erratically, whereas previously they worked flawlessly.

Now they don't present about 1/3 of the time. In addition, as soon as the driver sits in the car the other handles retract, so passengers are left standing outside. The dash icon shows the car still unlocked, but the control panel "Unlock" has to be pressed to make the handles extend again.

I notice that the voice command function now gives an error message if there is no connectivity. I am not sure, but previously I believe that the car accepted the command, even though it couldn't execute it -- at least I had not seen that error message before, and we drive in areas with no connectivity often.

@Jat/HaroldS - I'm on 4.2 and not seeing the door handle issues you are. I've had a couple of instances where the door handles wouldn't present automatically, but I think that was more to do with the car not sensing the fob than any particular error.

Surprised to see there will be a download/upgrade from 4.2 tonight at 2PM. We just got 4.2 last weekend. Well, life is full of surprises. Since everything is working, sure hope it still does tomorrow morning. Maybe we will have the mobile app! OK. It's late and I am wiped. Delusionsal.

2 PM is night? What's the sun doing so high in the sky?

I also got 4.2 (1.19.41) last weekend and received a new update yesterday. It is 1.19.42, which is still 4.2.

@reitman - did you you know that you can change the time to anything you want, or even install immediately?

Brian H
Ah, night and day, you are the one.

Thanks. Yup. Just wanted to be surprised in the morning.

My observations: having had no discernable problems under 4.1, had our first glitch the next day after the overnight download of 4.2. While driving in a 25 mph zone, where i had set cruise control to 25, I manually disengaged cruise control. A moment later, i attempted to re-engage, but instead got a yellow triangle error message telling me cruise control would not be available until i restarted the car. didn't realyply get a chance to do that, since we were in traffic, and on the way home. Once parked in our garage, I shut off the car, restarted, and error disappeared. Going to drive it to Half Moon Bay today, and will put it through the paces.

Anybody else notice this error?

Sorry, I assumed I was running 4.2 after I got the dialog and told it to install at 2am, but today I checked and it is still running 4.1. So, never mind about the door handle issues with 4.1 (unless it is a result of a failed upgrade).

Anybody know how to get the 4.2 upgrade after it failed to install at the scheduled time? I don't see any way to check for updates/etc.

@jat: You can select the "clock" icon next the "T" on the UI and the update window opens. You can then select the time for the update, or select the "Update Now" button.

There is no way to make the car check for updates. Some have had some luck in requesting Tesla to push the upgrade to their car. I received the 4.2 upgrade within hours of emailing and asking if they could push it to my car. Perhaps it was coincidence.

As previously posted, 4.2 did not install for me at 2 AM (Car was probably in sleep mode). I did "install now" yesterday after getting home. It takes about 30 minutes. No issues with 4.2 (sleep function is gone). Haven't had a chance to test the smoother acceleration in the release notes.

Anyone know the difference between 4.2 (1.19.41) and 4.2 (1.19.42) in terms of features? I received the first software update over a week ago, but then last night I was upgraded to 1.19.42. Release notes are identical to prior update though. Anyone have any insight into this most recent version?

@Nav66 - I had that cruise control problem once while running 4.0

@nickjhowe - We ran the car over 130 miles today, used cruise control in a variety of driving conditions and speeds, and all went well. Hopefully, that was our one glitch....

It happened to me just the once. No idea what caused it - seemed to come completely out of the blue. As you say, hopefully a one off glitch, but happening on two cars makes it a bug rather than a glitch.

I don't miss much about 4.1, but I do miss the reduction in overnight range loss. Putting the vehicle displays to sleep usually only cost me about 4-5 miles a night. The temperature here has been between 18 and 25 degrees for the last week. Last night I lost 12 miles. I was a bit surprised, but it was about 17 degrees in the garage so with battery heating and display drain I guess it's to be expected. I'll be happy when the sleep function is ready for prime time again.

X Deutschland Site Besuchen