Forums

JOIGNEZ-VOUS À LA COMMUNAUTÉ
INSCRIVEZ-VOUSIdentifiant

Replacing the Alpine nav / music system

Hi all,

I have a Tesla 2.5. I love everything about it except the Alpine music and Nav system. Frankly, it's unintuitive, the UI completely changes between Nav and music/radio, and it has pretty poor radio reception.

Has anyone replaced their head unit? Is it difficult? Can any garage/car audio place do it? Does anyone have any recommendations for a double height music and nav system?

Many thanks

Robert

there is the new sony system which is double DIN and uses TomTom nav soft with all it's goodies. HOWEVER, if your roadster is still under warranty then I would be careful since Tesla woods the warranty if you change any of the elctricalccomponents of the car without their consent! they site electricalcdraw and magnetic interference as their main worry. I will change mine when warranty out or Tesla approves more than just the Alpine.

/fb

felix is right. You have to get the new unit approved so I'm probably going to do the same. The Alpine unit is pretty bad for the amount of money.

Wow: that Sony looks great... I might have a word with the guys in the London dealership, and see if they'd change the head unit (for a fee, I'm sure :-)), and keep the warranty

Cheers

Robert

love to hear what they say..... mine said: sorry no can do. for the reasons I explained earlier........

good luck and maybe if we are enough people we can get the Sony system approved!

/fb

I also have a Tesla 2.5 . I also agree with the mediocrity of the Alpine system. I have paired both my Blackberry Bold and Iphone and cannot speak to anyone because they all claim that there is a tremendous echo and reverberation on the other end. I would also support any move to have the system replaced. I have had the car since Oct 2010 and this definitely is not acceptable.

Mitch
Toronto

My unit changes volume while playing back MP3's.
The UI for the audio is extremely poorly designed. Too many button presses, in a small touch screen area, just to even change bands. Not a good design to have to deal with, as it takes your attention off of driving to do even the simplest of operations.

When the New Roadster comes out in a year or two, I imagine the sound system and interface will be completely new. Alpine was the only provider with a compatible product when the Old Roadster was being designed, but those days are long gone, I think.

Reception issues are reportedly due to the carbon fiber body, and will not change with a new radio. Moving the antenna would help, but that doesn't require changing the head unit.

Echo & reverberation have to do with the shape of the cabin interior and the microphone placement on the dash. Those will be exactly the same if a new head unit were attached to the existing mic.

I seriously doubt that the Alpine was the only compatible unit. Tesla Motors also offered a JVC unit, and there have been double DIN units on the market for decades.

UI for music and navigation need to be different, don't they? I mean, they're completely different tasks. I would appreciate less of a delay when switching. Note that you can choose between artwork for the music or inset navigation prompts.

I also have problems with volume changes when playing MP3 tracks, but I mostly have AAC, ALAC, and lossless files, so I don't think it's specific to MP3. I have a hunch that there is some setting that would force the volume to be constant, but I have not found it (the manual is terrible for discovering the capabilities and settings).

As for the money, the entire Alpine setup costs less than $1,600. I doubt that the Rockford speakers and sub add much. The whole package used to be $3,000 so $4,500 is an insulting price to pay for such low-priced consumer electronics. I'm tempted to sell the components that I don't want, but I paid about 3 times their MSRP, so I can never get my money back, not even with over-zealous eBay auctioning.

Correction. I have volume changes (more like Bass/Treble level changes) on Radio, CD's with MP3's, USB drives with MP3's, and even regular CD's (which are RIFF WAV files).
I have hunted for some 'volume constant' setting too, and haven't found anything. But then it took me an hour to find out how to pair it to my iPhone, as menus are only 'sometimes' visible.

Yeah, the UI is different between the NAV and audio. And the NAV is actually a good design. Large buttons, screen centered, single presses. The audio UI is exactly opposite.

I don't know which is worse: that Alpine designed this thing so badly, or that the Roadster engineers didn't realize it's horrible design when they selected it.

I'd love it if the antenna was externalized. That would improve some of the reception issues.

Robert39,

What did the guys in London say about installing the Sony? I get my car next week (finally - ordered May 13, 2011) and I am sure the shortfalls of the $4500 Alpine will drive me insane.

I just turned Off the DEFEAT function in the settings, and I don't think the playback volume has changed since. This could be a red herring, though, as I've not listened for more than a couple of drives since then.

The Alpine manual seems to indicate that the DEFEAT function works with the optional IMPRINT accessory (which correct the frequency response changes introduced by the vehicle interior). I don't think that Tesla Motors includes the IMPRINT unit - although that would make it worth the $4,500.

For what it is worth, I really like this Alpine unit. Lots of HD radio in Colorado. Just got my car this week and the radio is great. I was told the bluetooth microphone location (bottom of dash between steering wheel and radio) is the problem with the hands free phone function. While I am sure there is some way to move it, the interior looks so nice it would be a crime to modify it. If anybody has relocated the speaker, I would like to hear/see how it looks and works. Thanks.

I'll try the defeat option, if I can find it :-)
I also think, but cannot prove, that it's related to when the car is getting hotter and the AC is close to diverting into the battery.

I am also in touch with both Tesla and Alpine. So we will see what can be done, although they changed the unit once already.

This is beginning to sound like an Elvis sightings list. I just noticed the volume wildly fluctuating up and down, and it almost seemed like it was tracking the accelerator pedal position with a noticeable lag. At other times, it seems related to hitting bumps. Maybe the volume changes just have no correlation to anything observable. I wish it would stop.

I don't think that the DEFEAT function has worked. I briefly thought that increasing the volume above 10 was stopping the volume changes, but that's not only very loud but I eventually caught it changing the volume above 10, maybe around 12.

Rsdio,
can you inform Tesla of this problem? They are treating it like it is only my car that has this problem.

I have captured the fluctuations with a small video camera, pointing at the dash to show the problem. The person I am in contact with at Alpine is desperately trying to replicate it, but has had no luck. When he heard the video/audio. he said that the variations he heard are clearly *not* due to Defeat' or 'Loudness' controls. I am starting to believe there is an issue with the way Tesla wired the system (power or speakers) that is causing it.

And yes, volumes from 11 and up are where I hear it. But I haven't had the volume above about 14 to see if it continues.

Hi, I have reported this to the Seattle Tesla team many times. Service has looked for a menu to defeat this.

If you want support, tell your Tesla contacts that VIN 1244 in Seattle has the same problem : all of the time (practically)!

Note: I recently confirmed that 'Defeat' merely turns off the Bass and Treble tone controls. That's basically all it does.

Meanwhile, I had 'Loudness' on for nearly two months. I just turned it off because it's too loud (I really just wanted the 'smile' EQ curve). Alas, the yoyo volume still continues after turning off 'Loudness'.

To reiterate, this happens at all volume settings, and while driving around.

At the risk of being repetitive, the sound system is the only thing about the car I would change. Whoever designed the control interface was demented and the radio reception and phone sound quality is really substandard. I bought an original Z3 when they first came out and vowed that BMW would never sell me another radio. It looks like I may have the same issue with Tesla.

rsdio: Yours is close to mine. I'm 1277.
The Chicago service guys have been dealing with it for a while, which is annoying for them, as I'm in Texas. They replaced the power amp under the dash (not the head unit). Seemed to solve it for a about a week. Now it's come back, but not as bad (yet). I'm thinking for generating a pure sine wave CD, and hooking up my oscilloscope to the amp and monitoring it. But that's the kind of nerd I am.

I wrote to both Tesla and Alpine enumerating my complaints. The UI sucks, and Alpine basically said it works as designed. Which I jsut have to keep saying 'the design sucks'. But they said they are not going to change it. But suddenly everyone was looking into the volume level changes. It was like kicking an ant hill.

scotty2451 and rsdio: Mine is 1247 in Atlanta.

I had the exact same volume problem but never could identify consistent modes/status of systems in the car to be able to consistently reproduce. It happened when listening to HD Radio, Sirius, and iPhone/iPod sources.(I have never played a CD in it) It happened when I was driving at various speeds as well as when stopped at a traffic light. I read the Alpine manual and searched every menu in the radio to see if the IMPRINT mode was disabled but couldn't find anything. I experimented with the DEFEAT mode but it didn't fix the problem. I turned the Sub Woofer ON and OFF with no luck. In addition the display would sometimes go blank and then come back. The Tesla Ranger replaced the display and the power amp on mine but not the head unit itself. I have not driven it that much since the replacement so I will have to retest including at the higher volume levels.

Also to commiserate the other issues: BAD RECEPTION of Radio stations (constantly switching from Digital to Analog), BAD Voice quality using the Hands Free Bluetooth with my iPhone4, BAD UI design with tiny buttons at the bottom of the screen making them hard to access.

My Roadster 2.5 has been in the shop for a week now. They have finally given up on a whine that completely drowns out any AM station when the vehcile is moving. Anyone out there ever try listening to AM? They tried swapping out the receiver, the RF pre-amp, and finally installed ferrite doughnuts to no avail.

Bob;
fascinating. Anyone else have/not have AM reception problems?

I predict Alpine will not supply the radio system for the Roadster 3!

(tried it in another thread... will try it one last time here)

Does anyone have a suggestion for a replacement to the single-DIN JVC stereo that shipped with the Roadster 1.5?

I have the same "experience" (if one can call it that) with the Alpine in my Roadster 2.5. I dug a little into the unit, and it appears to be an ARM based WinCE system. There are a few "hacked" replacements, some with desktops, some with improved functionality. It appears that the ARM image on the unit could be hacked to change quite a few of the major irritants.

I can volunteer to wrap up a Linux build with some useful music and video players and such if someone can sweet talk Tesla into parting with some specific information items about the unit so I'm not bricking mine as I hack it. Oh, and I'd need Tesla's semi-blessing, so that I'm not potentially voiding my warranty (can you believe it; hacking the radio potentially voiding the warranty on the entire car??).

@aki009

Would you mind sharing some links which show these hacked variants of the Alpine unit in the roadster? I have a spare one on my workbench would like to experiment a bit with it.

@SMOP Dang. Those things keep falling off a truck on the internet and it's so tough to keep track of where they came from... ;)

Seriously, though, here are a couple of potentially related links in no particular order:

http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=118573

http://www.gpspassion.com/forumsen/topic.asp?TOPIC_ID=143392

http://forum.xda-developers.com/showthread.php?t=1368340

http://code.google.com/p/navi-tools/source/browse/trunk/py-dumpnavi/?r=1...

http://www.wikihow.com/Modify-the-Navigation-System-of-an-Acura

aki009 thanks for the links,all this looks way to complicated and I am sure I would mess something up. I think the solution is to pull this unit out and replace it with something else. It looks like a lot of aftermarket hu vendors are pulling out of the market (probably due to proprietary dash setups of new car manufacturers) ...btw the third one is NSFW :)

I have the original JVC which was lousy and not working anymore. THinking about the Double Din with GPS and rear camera. Anybody has experience with this upgrade ?

@scubaguy

Not sure if its worth 4800. The Alpine INA unit in my 2.5's are not a massive improvement over the JVC in my 2.0. I still have not come across a really nice aftermarket double din unit. I think the aftermarket stereo business is dead. Most of the units out there are horrible. There was a new parrot unit that was built on android but I have not researched it. Looked pretty cool on youtube.

I believe the $4800 covers the installation of the Alpine, Backup camera, replacing part of your dash to move the vents.(is it worth it...I guess it depends on your peace of mind that Tesla stands behind it)...the use of the Alpine system was based on a custom job...http://www.teslamotorsclub.com/showthread.php/14877-Dr-Taras-Model-S-gets-customized! scroll down to the video of the Roadster

Please don't switch to Pioneer, its just as bad as Alpine.


X Deutschland Site Besuchen