version 4.3 fixed?

I got the notice to update maybe three weeks ago. I set it to update and got a message that it did not. After that i read about issues with walk away locking. My question is has that been fixed? I have a new message to update and since timed charge isn't important to me I but walk away locking is, I am debating doing it.

Anyone done it in the past week with no issues?


I installed 4.3 at 2 am Saturday March 30th and haven't noticed any new problems with walk-away locking. What was broken?

The early version of 4.3 (1.25.35) did not always update the security module which meant that doors would not stay locked; heard this was >1% of cars. The roll-out of that was suspended and newer versions without this problem are being rolled out now; according to reports on TMC the latest version is 4.3(1.25.45) and is stable but 4.3(1.25.40) is also out there and is also stable.

Correction: make that last post "<1% of cars". The rest is correct.

I'm still waiting to get any update at all! I'm still in v4.2 that I got from the factory.

Got my notice to update yesterday. 4.3 (1.25.45). All is good so far.

Well, I hope it's fixed, since it's installing on me right now. VIN 4086.

Has anyone that had 4.3 (1.25.35) gotten an update to 4.3 (1.25.45) without asking? I’ve got the former and am curious if I’ll get the mini-update automatically or will have to ask to get it.

No need to ask for it. They roll them out in stages. They don't want to make the cellular companies too upset.

@ Wayne3
Mine got re-updated when in for service today

Updated to 4.3 (1.25.45) two days ago. No issues.

Updated yesterday.
Everything OK.

I am still driving on the 4.2 version. It seems TM is updating one car at a time.

I upgraded to .45 several days ago and have had no issues.

Not yet fixed. I had version .40 on my sig vehicle, doors were not locking, had to disable the auto present and walk away door lock features. Just got version .45, and still not fixed. Called Ownership Experience, said they needed to call local service center for appointment. Told them not a rush, have gotten used to manually locking and unlocking car with key fob. A little disappointing, but guess that comes with territory of us being early adopters.

@jdb - I had a problem with a rear handle not presenting. Service had me pull the fuses for the door handles and replace them after 10 minutes. All good since then. It basically forced a reset. Maybe you could try this before taking it in. The manual does a good job of explaining how to reach the right fuses. Good luck.

Thanks alfafoxtrot1. All four of my doors do not lock ever since version .40 downloaded a couple weeks ago. Checked fuses per your suggeston, there is #40 for rear door handles but no fuse indicated for front door handles so guess will wait till service calls.

Have you tried rebooting everything? Sometimes that gets all the parts in synch.

I have a new issue with 4.3 that has popped up and was never an issue previously. My 17" display screen gets confused at dusk and goes back and forth from daytime mode to nighttime mode. It is rather annoying so I will have service check it out after I try a reboot to see if that fixes the problem.

I had problems with the AC fan not blowing hard when needed with .40, but it works correctly in .45.

Hi Brian H. Yes, did the screen reboot more than once to no avail. Have appointment late next week to bring car to service location to see if they can fix door unlock problem.

Anyone else have problems with their iPhone app working after version .45 update? Mine is not working at all (worked great before update). Grrrr.

Ver 4.3 rev~.45
All is good. App display projected miles with ideal label.

I meant both reboots.

I instaled V4.3(1.25.45) at 5:00 pm yesterday and no issues. My iPhone app worked fine immediately following. No issues ever so far - ...P07396 delivery 3/27/13 - flawless!

v4.3 (1.25.45)
Installed Saturday afternoon (PDT). Everything works fine.

My problem of walk-away locking appeared immediately after applying v4.3 (1.25.40). I now applied v4.3 (1.25.45) but the problem persists.

This despite of rebooting and pulling off fuse #32 Door Controls, Right Side and fuse #41 Door Controls, Left Side and left them out for 2 hours before reinserting them back and rebooting the 17" console display and instrument display.

I guess the Model S has evolved: Some will be obedient with a new update but on the other hand, some will be mischievous :)

CarlE - My iPhone app worked great until two days after updating to 4.3 (1.25.45). Consequently, the app was updated to ver. 1.1 the day after I got the 4.3 push and it worked until today. The app simply won't take my credentials after repeated tries - correct credentials confirmed thru I have reinstalled the app a couple times and still can't get in VERY frustrating.

I seem to have lost auto-tilt mirrors with this update. I tried resetting the position today assuming the personalization was lost thru the update but it didn't take. The option doesn't even appears on my settings screen anymore. I have the tech package with textile seats; I will be very annoyed if this is the result of some driver profile cleanup under the new options.

I had the same issue with the app. I changed my password to include only alphabets and numbers (I had special characters before). After the password change the app works with email and new password (doesn't work with username).

Received my update on 4.3 early saturday am. Door handle issue persists.

X Deutschland Site Besuchen