Forum

Bli med i fellesskapet
RegistrerLogg inn

Programvareoppdatering 4.0 Received

Who has received the latest update? I was told that updates go out in batches to make sure if there are bugs that the fewest number of people possible have an issue, but I am getting really anxious with this update. I was just curious how many have gotten the update so far.

V4.0(1.17.50)

Vin 207 got it this evening. My wife is going to vomit if I walk by the car one more time and ask her if she sees how the handles automagically extend. I absolutely love this car!

Just tell her to keep well back. The stomach acid wouldn't be kind to the finish.

Still no update for me (Sig VIN 871). Was it something I said?

VIN # 532, Received the update Wednesday night, December 5th. Very nice update to squash some bugs in the software and improve the functionality of the car!

mkh;
Yes. Try politeness instead of raging insults next time, 'kay?

;p
;)
LOL

Vin 939. Got the update Friday. One glitch Saturday night: after putting the car in park, when I tried to open the left rear door to let my son out, it wouldn't open. Then the handle retracted (others remained open, despite sync door handles enabled). I could not get the handle to extend, so I let my son out the right rear door. Then I drove the car to a parking spot and tested the door handle and it worked fine.

Sig 692/VIN 00495...

Got my 4.0 upload yesterday while at work! Noticed a few things that I haven't seen reported anywhere so I'm trying to understand if these behaviors are bugs or what!

1. Acceleration is certainly smoother and perceptibly quicker as indicated in release notes; BUT, regen braking is ALSO very noticeably changed! In standard mode, it is much more aggressive at slow speeds. As the car slows to close to Zero MPH, the car continues to move forward as in CREEP mode without actually stopping. If I touch the brakes, car stops. This is very new behaviour for my car. Prior to 4.0, regen braking stopped providing braking power at a much higher speed such that you had to use the brake earlier in stopping sequence. Has anyone else noticed this change?

2. CREEP Mode is now grey'd out and can't be selected! I didn't find anything in the release notes about eliminating CREEP mode?
It has apparently been removed as a feature although the selection is still there but can't be programmed either to enable or disable. The behavior is that it is DISABLED.

3. Lost the driver profile setting for mirrors when in Reverse. I had to reprogram both forward and reverse settings for both outside mirrors after the update. No big deal, just unexpected!

4. Brightness was reset to ZERO percent! Caught me by surprise and took me a second to realize that is what had happened! After readjusting, all seems to be back to normal...aka, it hasn't gone back to ZERO again.

5. Not a bug I hope - Performance of Maps is much faster than before! Both when displaying Traffic and when not! Thanks.

So much for things I found after 24 hours on 4.0 SW update!

cheers,

jdiii

@jdt3m -

1. Yes, I thought the regen had changed noticeably. Kind of disconcerting that it gets really strong at low speed, whereas before it backed off at about the same speed level.

2. Haven't noticed anything about Creep, since I don't use it.

3. Yes, same here. As you say, easy to reset.

4. I can't seem to bring up the brightness control on the roller wheels now, although I reset it in the Control Panel. I think perhaps I don't completely understand the modifications of the right wheel and perhaps the brightness control is in that set of menus.

5. I noticed sort of the opposite. The car has a very difficult time establishing connectivity, even though it had no problem before in the same areas.

Other issues:

A. The sound system zeros out when the car goes to sleep. The prior operation is lost and the system has to be reset manually.

B. The selection of metric display only lasts until the car goes to sleep, then everything goes back to English. This one is quite annoying, since I understood that this selection was to be part of the driver profile. I thought perhaps when I readjusted the tilt down mirrors and saved that to my profile it would save the metric settings, but it didn't. Grrrrr.

Overall this is a great update, and the features are ones that we wanted and will use regularly. I'm sure that these few issues can be fixed shortly.

Did anyone notice how long the actual SW update took for your cars? I finally had the notification this morning and set the car to update after my workout this morning an hour before I planned to leave for the office. When I went to leave an hour later it did not appear to be done. The car was off and not responding.

This is my fourth SW update and none of them have taken an hour so I was just wondering if this was expected and would love to hear form someone who
a) has actually done the update (no thanks, on speculations),
b) watched how long it took.

Just want to make sure my car is not somehow "bricked".

Thanks for any help.

@gimp_dad

the update takes 2+ hours depending on your 3G connectivity. I noticed that having a strong 3G connection seems to enable quicker updates generally and in this case enables the update to be done in just at 2 hours!

Vin #450 no updates yet ????

I would recommend doing a reboot of both the touchscreen as well as the instrument display just after you install the update. I had some issues right after the update, but after rebooting, it seemed to take care of the glitches I had.

To reboot, hold down both the left and right steering wheel scroll wheels until you see one of the screens go dark. I can't remember which screen it reboots. The other reboot will happen when you hold down both the left and right steering wheel control buttons above the scroll wheels. You have to hold down one of the button combinations for quite a long time (Maybe 30 seconds to a minute) to get to the reboot (The screen will go dark).

Creep mode should be working (You should be able to turn it on and off while in park), so if it appears to be disabled, the reboot should bring it back.

No update yet! VIN 192. What's taking so long!! I want the magic door handles.

Vin 1709 I got it. I had an issue where my power was reduced s they bumped me up the list to fix it.

Harold I Definitly have creep working, I would reboot your screen to see if it fixes. My fav parts of update are the smoother throttle (you can barely press the pedal now vs. before you had a dead zone), the voice update with slacker search, the letters for scrolling, and the door handles of course!

I read in Wired Magazine something I didn't realize. The software is apparently uploaded to the car while out driving around when the 3G signal is strong. Then when you plug in the car at home, it displays the clock which allows you to initiate the installation. If correct, the "bricking" process time should be independent of the 3G connection at the time of installation. Anyone have confirmation of this? Here is the article:
http://www.wired.com/autopia/2012/12/tesla-model-s-4-0/

Just another positive thing about the V4.0 update. Previously, the energy use by the climate control and other ancillary systems wasn't reflected on the Kw meter in the speedo cluster. Now at least some of those power uses are included. For example, when the car is sitting still and the heater is on, the kilowatt draw now shows in the dial. I find that helpful.

The metric settings still don't "stick", and have to be reset after every "sleep" period, but a Tesla rep tells me they are working on that issue.

As other posters have noted, the change in throttle (and regen) taper is an excellent improvement once you make the mental adjustments.

Vin 626 hasn't gotten it yet. :-(

quirky things after 4.0 udpate installed:

in addition to those I already mentioned, I have now had 2 instances of the:

"Tire Pressure too Low" - check Tire pressure Warning indication. This indication goes away after a few minutes. Has happened on 2 different occasions in the past week.

I also had a "unknown error bit nnnnn" Warning that vanished before I could take a photo so didn't get the full readout.

Still can't get CREEP mode back; not a problem since I wouldn't use it anyway but suspicious that it is grey'd out.

My SW update info: V4.0 (1.17.50)

I wish there was a way to submit a bug report directly to TMC rather than just posting to various forums.

@jd3tm

Have you tried rebooting both screens as suggested by others?

If screen reboot doesn't do the trick, I assume you've put the car in Park to switch to Creep mode? I've noticed that in my car a few times the Creep button was disabled until I was in park and my foot was on the brake.

@stephen.pace...

Ahha!!! The secret seems to be having to have one's foot on the brake in addition to being in Park. That enabled CREEP mode to be set (not grey'd out). Guess it isn't a bug; rather, a Feature!

;-)

Ahha!!! The secret seems to be having to have one's foot on the brake in addition to being in Park. That enabled CREEP mode to be set (not grey'd out). Guess it isn't a bug; rather, a Feature! (jd3tm)

That description sounds an awful lot like hill assist, which has also been promised for some time now. How does it behave on an incline? Would be weird though if they rolled that out w/o mentioning it in the release notes.

@jd3tm - I posted last night about my flat tire and the sensors, but if you have the 21" wheels then make sure your tire pressure is around 45 psi, otherwise you will keep seeing the tire pressure warnings for a short bit until the tires warm up and increase their psi above the warning threshold.

Still waiting for the update. I can't wait for the letters for my flash drive music and the auto door handle extension. I am crossing my fingers that this will also fix my Homelink.

Is there any rhyme or reason to the order in which they are rolling out the updates? Has anyone on the East Coast received v4.0. I'm in NJ (VIN 660) and have not.

WiFi in Jan.?

@jamesgx,

Good to know...yep, I have the 21" wheels. will check tire pressure tonite.

All,

I haven't seen any rhyme or reason to the order of rolling out of V4.0 update. I will say that I got an email FIRST which formally announced the SW update; then, approx. 24 hours later, I got the alarm clock indicating I had an upgrade pending and I should pick the time to enable the update.

Essentially, I got in my Model S to go to work and noticed the alarm clock. I let the installation of the update happen while at work!

I gather the code had already been downloaded to the vehicle by the time the alarm clock displayed.

I am in San Jose, CA. Sig 692, VIN 00495 (although I gather neither Sig # or VIN # are used to decide when you get the upgrade).

cheers

All - for what it is worth I used to work at a company called Dash Navigation, where we were building a connected GPS device and we rolled out software updates over the cell network like Tesla does. Note that this was pre-iPhone days, and the device was basically a Garmin unit with cellular data and wi-fi.

Anyway, the way we rolled out updates was to take users and put them into groups and roll out to ever larger groups so long as we weren't seeing any issues in the previous smaller group. I would bet that Tesla is doing the same thing and that they want their groups to be spread out geographically as well as based on configuration.

Just a guess, but one based on some experience.

Can you please tell me how I would know when the Update has occured?
I have multiple softwrae related issues, like the Charge Port wont open, except from the inside release, the Google maps freeze, or the pointer travels all over, or I cannot turn the radio on, or the camera will only stay on the top part, etc. Have tried re booting with partial success. I am told that the Update will fix all this.


X Deutschland Site Besuchen