Forum

Bli med i fellesskapet
RegistrerLogg inn

Tesla unaware of GPS problems?

I picked up a Model S last week and the GPS has been completely wonky. Looking at the forum it seems like a lot of people who purchased recently have the same issue. However when I called my local service they were unaware of any problems. They told me to call the 877-78TESLA number for Ownership help. The rep there also told me he had not heard of any GPS problems at all. I mentioned this forum and he said he checked regularly and was very surprised to hear of GPS issues.

So if you are among the recent buyers who have experienced the GPS issues I suggest you add on to this thread and also call 877-78TESLA to let them know as I don't think they will fix it if they don't know about it.

BTW - This is not just the limitations of Google maps. The issue is that the GPS will often loose the position of the car in the middle of a drive for no reason. It often puts the car in the middle of a filed or several blocks over. The car gets "lost" for maybe a minute or so and then it often pops back in. But it will do that back and forth continuously. This happens for me every time I use it. Sometimes the map goes wonky too. And at times the car location is different on the big screen and the dashboard screen, with even has different turn instructions sometimes. When the GPS looses the car position it starts giving out wrong turn directions and quickly gets you lost. For this reason I have to bring a separate GPS until with me as the Tesla one is completely unreliable.

Does the car get lost on a N up orientation as well?

@MarioA Same here and I too have seen a few forum threads about this same issue. We are not alone. I had a ranger visit for this issue but it was not resolved. Frustrating.

@Bighorn The issue persists, even if you change to N up orientation. I've tried no satellite view, no traffic, various combinations, with no resolution. Mine is generally wonky but from time to time, it does know where I am.

Curious how sometimes it even shows me moving sideways, like a crab, or in circles in the same spot. GPS often has me correct then drifts off even perpendicular to direction I'm going. The ranger tried working with the antenna but no help.

I picked my car up last week and have the same problem / issues. Today was the worst since I needed to use navigation to get me to an appointment at a location I hadn't been to before. The Google Maps nav AND Garmin in-set were both off by at least a 1/4 mile. Had me on surface streets / vacant fields / middle of buildings as I drove on the freeway!

It does pop back eventually -- but on this trip it took a good 10 minutes.

Service center hadn't heard about it and suggested the normal (which I had done already) system reboots.

@Dripps
Very curious--hope it's resolved ASAP. I remember hearing that getting the NAV to have heading up was going to be complicated, but this behavior is tough to grasp.

I've also tried rebooting and all possible map configurations and nothing helps. Its disconcerting that neither the service center nor the Ownership group have heard about this yet but hopefully they will soon. It is definitely NOT the usual limitations of GPS units. I've had many GPS units over the years and they never behaved this badly. And from what I read on the forum many people have units that work perfectly. For those of us with the problem it is not at all subtle. You absolutely live in fear of having to depend on the GPS. So that means that either there is bad batch of hardware or there is some issue with the ver 5 software.

Have we determined that all the people with problems have ver 5 software? I do.

Well they know now.l just got a call from Tesla and they have reported the problem to the VP of service. Yeah! And they forwarded this posting on the forum. So again Yeah! I love this car and I'm encouraged that they will fix this problem. If anyone else has similar GPS issues please let them know in this string because they are listening and are responsive. The more info we give them the more likely they will be able to solve this problem. Very encouraging response from Tesla.

I also have the same issue - exactly as you describe it. One thing I noticed today was that the problem seems to nearly disappear when I changed the map from "north up" to "heading up". Hopefully this can be solved with a simple software update.

My car, delivered mid-July, with 4.5 software has been flawless and extremely accurate.

There are about 8 other owner reports of this issue in another thread: NAVIGATION SYSTEM LOSES POSITION FREQUENTLY.

All recent deliveries, all running 5.0.

We are almost all reporting the same symptoms. Ours is in the Denver SC currently and they will be evaluating this problem tomorrow.

I picked up my MS two days ago (running 5.0), and have only used the nav twice, but experienced similar issues to posters above. While I was driving on the freeway, it started giving me directions as if I was heading the other direction of I-5 even though those lanes were a good 100 feet away at the time.

I can't remember if I had it set to "North Up" or "Heading Up" at the time.

Same GPS problem here...occasionally has my position off by several blocks. Picked up my S on 9/11/13, software 5.0

My car is a month old and is running 4.5. There have been no problems with the GPS.

The GPS on my car (delivered May 31) has never failed, but a loaner I drove last week ( VIN 16xxx, 4.5 software) had this problem. Twice, during navigation to a destination, the navigation arrow froze at some point on the map and didn’t recover, despite my attempts to pan , zoom, re-center, etc. I had to cancel navigation for the GPS to resume.

At least for this one car, the issue happened on 4.5 software. I did report it to the service rep, when I returned it.

Picked up my car 9/7/13 and also seeing the GPS issue of having trouble properly locating the car. Plus I already had to reboot my touch screen... Love the car though!

GPS has been acting screwy. Tells me to make a left off the Garden State Pkwy, when there is no left

I picked up my car 2 weeks ago and only had that happen on the first day and I think the day after. But it only happened really briefly and it was at intersections where there were several forks in the road so it looked like it got confused. But once I turned it resolved itself.

Sometimes it will move from the North Up and deviate back to the other setting and I'll have to tap it. Also, when you are in the North up setting it's annoying seeing the street names backwards or upside down. Not sure if they can fix that either?

Picked up my car last Saturday (9/7) and have noticed the same issue. The map will show me off of major roads although close to my actual location.

Same issues as above. Car delivered on 8/31, version 5 Software. The GPS will locate the vehicle perfectly if its parked, but once moving, whether its on I5, or in downtown streets, it seems to get off by a block or so, and then it gets thoroughly confused, and gets further and further from its actual location, with non-sensical corrective directives.
Use your I Phone until they figure this out.

Brand new MS picked up on 2013/9/10. GPS is pretty much randomly located within about 1/2 mile from the car. I mentioned this to the service tech, who said there's a beta of version 5 that's testing a fix for it.

A post V5 beta, that is.

My only problem with the GPS Nav. is that the voice commands are slow. Many times it "turn" at a certain intersection just as I'm going through it, or after I've already gone through it. This is with 4.5. Usually it's not an issue, as it happens mostly when I'm ignoring the instructions to go on a route other than what the Nav. system wants.

As an update: I had called the service center (in San Diego) yesterday and they hadn't been aware of any GPS problems. They suggested I reboot the systems and to get back to them. I did the reboots and had same problems so was going to test it out today a few times before calling back.

Before I could even do that -- I got the e-mail below from San Diego service center. I absolutely love the initiative they took and the responsiveness! Love this car.

______________

Hello XXX.

We have remotely diagnosed your vehicle regarding the navigation issues that you’ve been having. However, this issue will require us to have the vehicle here at the shop. The engineers have some test for us to run on your vehicle, and we will need to perform these tests here.

I will be able to provide a Model S loaner for you while we are working on your vehicle. The soonest I have one available is Monday Sept. 23rd. I can do that day, or any day after. Please let me know what works best for you.

Thank you!
Jeff H.

I have had the same problems since picking up my MS on Sep 6th.

Just got mine delivered today. It has 5.0 firmware. Noticed the same issue when I drive back from the service center to home (~3 miles). Exactly as described on the off-road / wrong street issue. I was too frustrated and had to cancel the nav route.

The only problem we have had with GPS is that We cannot direct it to avoid the Illinois Toll-way, a rubble covered parking lot. I can direct my Garmin to avoid this ditch criminally called a road. Garmin calls it selective routing. So far most of the damage to my Signature P85 S has been from road rubble being kicked up and dropped from Toll-way athority dump semis, passing me in both directions, hauling away 50 miles of rubble. Even if I refuse to follow the turn-by-turn instructions to get on the Toll-way, the turn-by-turn keeps directing me back to a public disgrace I don't want to park on. The last trip in Chicago, the Touchscreen GPS showed that I90 was jammed to a stop from I290 interchange to the Whirlpool, yet at every intersection I was directed back to I90. After a lot of wrong directions back to the Tool-way parking ditch, I shut off the turn-by-turn voice and followed the Garmin on the surface streets.

Never had any issues until I upgraded to 4.5. I'm now finding that traffic data will not refresh. If I change the zoom, it will update, but if I then revert to the previous zoom level, traffic reverts to the stale image.

Called Ownership team yesterday after getting stuck in a major traffic jam (map showed all green on 95S near the Philly airport...after getting stuck, I zoomed in and the traffic showed solid red/black!). They said this is the first they had heard of this issue and that they would look into it.

I'm seeing the same GPS issues as the OP. I picked up my P85 on 7-29 and have v. 5.0

Guess this is another reason 5.0 is not out OTA yet....

O

My delivery was 9/5 with firmware 5.0 and I'm also having the GPS being as far as a quarter mile off issues. Sometimes the Google maps just start spinning around the location arrow for a good 30 seconds while it tries to reorient. I had it in to service this in Villa Park yesterday. They said they tried a new GPS antenna and a GPS specific firmware update. No luck fixing it and I'm scheduled to return for an unknown to me (and maybe them) next step in a few weeks.

Lovin' the car otherwise!

My GPS (4.5) was in really bad shape. At several points, it had me in the middle of the Pacific ocean or Africa. I even sent snapshots of that to Tesla Service in Rockville. It would also frequently stop updating and leave me miles behind my actual location, sometimes taking an hour or more before it would update to my actual location. Navigation was pretty much worthless.

They finally took it in and replaced the whole front screen unit. Took two weeks to get my car back (I did have a P85 loaner, so all good there). It's been working great ever since.


X Deutschland Site Besuchen